Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Ошибка при установке apache  (Прочитано 2763 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Randes

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Ошибка при установке apache
« : 03 Май 2010, 17:08:46 »
Во время установки apache вылазит:

ERROR: Module reqtimeout does not exist!
dpkg: error processing apache2.2-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apache2-mpm-worker:
 apache2-mpm-worker depends on apache2.2-common (= 2.2.14-5ubuntu8); however:
  Package apache2.2-common is not configured yet.
dpkg: error processing apache2-mpm-worker (--configure):
 dependency problems - leaving unconfigured

А при старте апачте вылазит:
apache2: symbol lookup error: apache2: undefined symbol: apr_os_uuid_get

Не подскажите как это можно вылечить?

Оффлайн Solaris10

  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Ошибка при установке apache
« Ответ #1 : 03 Май 2010, 17:44:19 »
Расскажи, как ты ставишь.

Оффлайн Randes

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Ошибка при установке apache
« Ответ #2 : 03 Май 2010, 17:56:30 »
sudo apt-get install apache2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common libapr1
  libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
Suggested packages:
  apache2-doc apache2-suexec apache2-suexec-custom
The following NEW packages will be installed:
  apache2 apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common
  libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/3,328kB of archives.
After this operation, 10.1MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously deselected package libapr1.
(Reading database ... 137879 files and directories currently installed.)
Unpacking libapr1 (from .../libapr1_1.3.8-1build1_i386.deb) ...
Selecting previously deselected package libaprutil1.
Unpacking libaprutil1 (from .../libaprutil1_1.3.9+dfsg-3build1_i386.deb) ...
Selecting previously deselected package libaprutil1-dbd-sqlite3.
Unpacking libaprutil1-dbd-sqlite3 (from .../libaprutil1-dbd-sqlite3_1.3.9+dfsg-3build1_i386.deb) ...
Selecting previously deselected package libaprutil1-ldap.
Unpacking libaprutil1-ldap (from .../libaprutil1-ldap_1.3.9+dfsg-3build1_i386.deb) ...
Selecting previously deselected package apache2.2-bin.
Unpacking apache2.2-bin (from .../apache2.2-bin_2.2.14-5ubuntu8_i386.deb) ...
Selecting previously deselected package apache2-utils.
Unpacking apache2-utils (from .../apache2-utils_2.2.14-5ubuntu8_i386.deb) ...
Selecting previously deselected package apache2.2-common.
Unpacking apache2.2-common (from .../apache2.2-common_2.2.14-5ubuntu8_i386.deb) ...
Selecting previously deselected package apache2-mpm-worker.
Unpacking apache2-mpm-worker (from .../apache2-mpm-worker_2.2.14-5ubuntu8_i386.deb) ...
Selecting previously deselected package apache2.
Unpacking apache2 (from .../apache2_2.2.14-5ubuntu8_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for ufw ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up libapr1 (1.3.8-1build1) ...

Setting up libaprutil1 (1.3.9+dfsg-3build1) ...

Setting up libaprutil1-dbd-sqlite3 (1.3.9+dfsg-3build1) ...
Setting up libaprutil1-ldap (1.3.9+dfsg-3build1) ...
Setting up apache2.2-bin (2.2.14-5ubuntu8) ...
Setting up apache2-utils (2.2.14-5ubuntu8) ...
Setting up apache2.2-common (2.2.14-5ubuntu8) ...
[b]ERROR: Module reqtimeout does not exist![/b]
dpkg: error processing apache2.2-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apache2-mpm-worker:
 apache2-mpm-worker depends on apache2.2-common (= 2.2.14-5ubuntu8); however:
  Package apache2.2-common is not configured yet.
dpkg: error processing apache2-mpm-worker (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apache2:
 apache2 depends on apache2-mpm-worker (= 2.2.14-5ubuntu8) | apache2-mpm-prefork (= 2.2.14-5ubuntu8) | apache2-mpm-event (= 2.2.14-5ubuntu8) | apache2-mpm-itk (= 2.2.14-5ubuntu8); however:
  Package apache2-mpm-worker is not configured yet.
  Package apache2-mpm-prefork is not installed.
  Package apache2-mpm-event is not installed.
  Package apache2-mpm-itk is not installed.
 apache2 depends on apache2.2-common (= 2.2.14-5ubuntu8); however:
  Package apache2.2-common is not configured yet.
dpkg: error processing apache2 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
No apport report written because the error message indicates its a followup error from a previous failure.
                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                    ldconfig deferred processing now taking place
Errors were encountered while processing:
 apache2.2-common
 apache2-mpm-worker
 apache2
E: Sub-process /usr/bin/dpkg returned an error code (1)

Оффлайн Protopopulus

  • Старожил
  • *
  • Сообщений: 1686
  • ちのう の きょうかん
    • Просмотр профиля
Re: Ошибка при установке apache
« Ответ #3 : 03 Май 2010, 18:06:20 »
sudo apt-get purge apache2
sudo apt-get autoremove
sudo rm -r /etc/apache2
sudo apt-get update
sudo apt-get install -f apache2
Если ты владеешь знаниями, то и знания владеют тобой. (с) Protopopulus

Оффлайн Randes

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Ошибка при установке apache
« Ответ #4 : 03 Май 2010, 18:22:49 »
не помогло... таже беда....

Оффлайн Protopopulus

  • Старожил
  • *
  • Сообщений: 1686
  • ちのう の きょうかん
    • Просмотр профиля
Re: Ошибка при установке apache
« Ответ #5 : 03 Май 2010, 19:03:08 »
Какая-то странная ситуация. Неудовлетворенные зависимости... А откуда сервер ставится? Какой репозиторий?
Если ты владеешь знаниями, то и знания владеют тобой. (с) Protopopulus

Оффлайн Randes

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Ошибка при установке apache
« Ответ #6 : 03 Май 2010, 19:37:01 »
Ставил с родного репозитория. Полсе updat'a с 9.10 до 10.04 начались такие проблемы. 9.10 стояла 64 батная.
Избавился от проблемы переставив Ubuntu заново на 32 битную.

 

Страница сгенерирована за 0.056 секунд. Запросов: 22.