Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Не возможно удалить пакет Flashplugin-nonfree  (Прочитано 943 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн VAstalkerVA

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
  • Мы есть то, что мы думаем (Будда)
    • Просмотр профиля
Проблема состоит в следующем:
После обновления Ubuntu 8.04 до Ubuntu 10.04. Перестал функционировать Flashplugin-nonfree.
При попытке удалить плагин столкнулся со следующем объявлением в Ubuntu:

dpkg: не удалось обработать параметр flashplugin-nonfree (--remove):
 Пакет абсолютно неработоспособен -- перед удалением его
 следует переустановить.
При обработке следующих пакетов произошли ошибки:
 flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:


Следом пытался установить по совету системы, выдало такое объявление:

Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
  flashplugin-nonfree: Зависит: flashplugin-installer но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).

Пытался удалять и ставить через терминал и через синоптика, и через aptitude.
Везде выдает одно и тоже.

Версия плагина 10.0.1.218+really9.0.262.0ubuntu1
Обновлялся я через Update-manager

Прошу прощения если моя тема повторяется, я до этого просматривал форум и не смог найти подобной темы, заранее благодарен за помощь.
Тысячами незримых нитей обвивает тебя Закон. Разрубишь одну - преступник, десять - смертник, все - Бог.

Оффлайн Lian

  • Участник
  • *
  • Сообщений: 139
    • Просмотр профиля
    • Новый проект для начинающих
Re: Не возможно удалить пакет Flashplugin-nonfree
« Ответ #1 : 06 Май 2010, 08:45:44 »
Ставь новую версию на чистый диск. Иначе проблемам не будет конца.
Проверено необнократно, при обновлении всегда глюки

Оффлайн VAstalkerVA

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
  • Мы есть то, что мы думаем (Будда)
    • Просмотр профиля
Re: Не возможно удалить пакет Flashplugin-nonfree
« Ответ #2 : 06 Май 2010, 08:55:27 »
На чистый нет возможности поставить у меня нету резервного диска большого размера, а информации слишком много. По этому и приходится обновлять. Так, что вариант с полным сносом мне не подходит. Потому и обращаюсь за помощью в решении данной проблемы.
Тысячами незримых нитей обвивает тебя Закон. Разрубишь одну - преступник, десять - смертник, все - Бог.

Оффлайн pipe

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5546
    • Просмотр профиля
Re: Не возможно удалить пакет Flashplugin-nonfree
« Ответ #3 : 06 Май 2010, 09:25:43 »
sudo apt-get -f install на что материться то ?

Оффлайн VAstalkerVA

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
  • Мы есть то, что мы думаем (Будда)
    • Просмотр профиля
Re: Не возможно удалить пакет Flashplugin-nonfree
« Ответ #4 : 06 Май 2010, 09:30:10 »
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Исправление зависимостей... Готово
Будут установлены следующие дополнительные пакеты:
  flashplugin-installer flashplugin-nonfree
Предлагаемые пакеты:
  konqueror-nsplugins ttf-xfree86-nonfree xfs
НОВЫЕ пакеты, которые будут установлены:
  flashplugin-installer
Пакеты, которые будут обновлены:
  flashplugin-nonfree
обновлено 1, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 107 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 0B/21,4kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 61,4kB.
Хотите продолжить [Д/н]? y
Предварительная настройка пакетов ...
dpkg: не удалось обработать параметр flashplugin-nonfree (--remove):
 Пакет абсолютно неработоспособен -- перед удалением его
 следует переустановить.
При обработке следующих пакетов произошли ошибки:
 flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)


Вот, что выдает на: sudo apt-get -f install

Пользователь решил продолжить мысль 06 Май 2010, 09:39:58:
Up, проблема все еще остро волнует, и я с нетерпением жду советов профи.
« Последнее редактирование: 06 Май 2010, 14:42:25 от VAstalkerVA »
Тысячами незримых нитей обвивает тебя Закон. Разрубишь одну - преступник, десять - смертник, все - Бог.

Оффлайн wulfgar93

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Не возможно удалить пакет Flashplugin-nonfree
« Ответ #5 : 06 Июнь 2010, 05:46:17 »
та же проблема, нет решения?
На самом деле в жизни нет никакого смысла... Смысл в том, чтобы найти себе то, чем заняться... (с) Орочимару

Оффлайн tolstyj

  • Участник
  • *
  • Сообщений: 186
    • Просмотр профиля
Re: Не возможно удалить пакет Flashplugin-nonfree
« Ответ #6 : 06 Июнь 2010, 06:03:58 »
Я в свое время имел аналогичную проблему с видеодрайвером для NVidia.
Решил методом описанным здесь http://www.cyberciti.biz/tips/troubleshooting-debian-ubuntu-package-upgrades-removals.html

Оффлайн VAstalkerVA

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
  • Мы есть то, что мы думаем (Будда)
    • Просмотр профиля
Re: Не возможно удалить пакет Flashplugin-nonfree
« Ответ #7 : 09 Июнь 2010, 07:33:19 »
Большое спасибо, за ваши советы, но справился другим методом. К сожалению я сейчас не смогу подсказать точный файл который редактировал, так как было испробовано очень много методов, но помню точно, что проблема ушла только после того как почистил информацию о данном пакете. Просто удалил из перечня пакетов. И тогда смог удалить этот пакет.

Тему можно считать закрытой
Тысячами незримых нитей обвивает тебя Закон. Разрубишь одну - преступник, десять - смертник, все - Бог.

Оффлайн konst-t

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Не возможно удалить пакет Flashplugin-nonfree
« Ответ #8 : 09 Июнь 2010, 22:30:07 »
Мне помогло вот это http://sshd.by/ru/27

 

Страница сгенерирована за 0.058 секунд. Запросов: 22.