Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Помогите отключить тачпад.  (Прочитано 19174 раз)

0 Пользователей и 1 Гость просматривают эту тему.

flowers

  • Автор темы
  • Гость
Помогите отключить тачпад.
« : 07 Май 2010, 16:45:13 »
Ничего не помогает. Только fn+f7. Никакая прога, ни скрипты. Если и отключается, то на некоторое время, потом опять по новой.(Ubuntu 9.10)

Оффлайн r.o.m.a.N

  • Активист
  • *
  • Сообщений: 757
  • Debian Testing | KDE
    • Просмотр профиля
Re: Помогите отключить тачпад.
« Ответ #1 : 07 Май 2010, 16:59:18 »
Надо насовсем его отключить? Из вышесказанного не все я понял.

Пользователь

  • Автор темы
  • Гость
Re: Помогите отключить тачпад.
« Ответ #2 : 07 Май 2010, 17:01:08 »
настройки для тачпада есть в gconf-editor (проверял на 10.04)

запустить программу командой
gconf-editor
и перейти в
/desktop/gnome/peripherals/touchpad/


там поставить галку напротив интересующего пункта (когда нажимаешь на название, то внизу показывается описание функции)

позже могу команду написать, которой отключается тачпад.

flowers

  • Автор темы
  • Гость
Re: Помогите отключить тачпад.
« Ответ #3 : 07 Май 2010, 17:01:33 »
Насовсем, но с возможностью его включения :)

Пользователь решил продолжить мысль 07 Май 2010, 17:04:54:
В версии 10.04 все работает. А в 9.10 нет. Гикон не помогает.
« Последнее редактирование: 07 Май 2010, 17:04:54 от flowers »

Оффлайн dimas000

  • Старожил
  • *
  • Сообщений: 1437
  • Ubuntu 9.10 @ 2.6.34
    • Просмотр профиля
Re: Помогите отключить тачпад.
« Ответ #4 : 07 Май 2010, 17:28:04 »
https://forum.ubuntu.ru/index.php?topic=90411.msg685921#msg685921
здесь и рядом. скрипт оставляем скриптом и запущаем из консоли, или же вешаем на ярлык/хоткей, а то можно даже применить фантазию и создать правило для udev на отключение тычпада при подключении мыши и обратно (кстати, где-то я про это уже читал)
лучше на "ты"

flowers

  • Автор темы
  • Гость
Re: Помогите отключить тачпад.
« Ответ #5 : 07 Май 2010, 17:42:42 »
Все равно не понятно.
Вот у меня устройство "SynPS/2 Synaptics TouchPad"   id=7
Скрипт создала, на кнопку назначила.
как конкретно будет выглядеть скрипт?

Оффлайн absemetov

  • Активист
  • *
  • Сообщений: 401
  • LMDE 2011 01
    • Просмотр профиля
    • absemetov.org.ua
Re: Помогите отключить тачпад.
« Ответ #6 : 07 Май 2010, 17:50:54 »
sudo /usr/bin/synclient TouchpadOff=11-вкл
0-выкл

Чтобы заново не включался отключи опцию в настройках клавиатуры "Выключать тачпад при наборе текста" вроде так, уже не помню.

flowers

  • Автор темы
  • Гость
Re: Помогите отключить тачпад.
« Ответ #7 : 07 Май 2010, 17:55:24 »
Не помогает. Какой-то неуемный тачпад.

Оффлайн dimas000

  • Старожил
  • *
  • Сообщений: 1437
  • Ubuntu 9.10 @ 2.6.34
    • Просмотр профиля
Re: Помогите отключить тачпад.
« Ответ #8 : 07 Май 2010, 17:56:41 »
Цитировать
Все равно не понятно.
Вот у меня устройство "SynPS/2 Synaptics TouchPad"   id=7
Скрипт создала, на кнопку назначила.
как конкретно будет выглядеть скрипт?
поправь значение для переменной id и всего делов. вместо девятки 7 поставь.
Цитировать
sudo /usr/bin/synclient TouchpadOff=1
(Нажмите, чтобы показать/скрыть)
через synclient у меня чего-то там не вышло... через xinput все прекрасно получилось
лучше на "ты"

flowers

  • Автор темы
  • Гость
Re: Помогите отключить тачпад.
« Ответ #9 : 07 Май 2010, 18:04:32 »
Короче создала скрипт
#!/bin/bash
synclient TouchpadOff=1
поставила  в автозагрузку. Отключила disable touchpad while typing.
Перезагрузилась и он от меня отвязался, слава богу.
Но все равно всем спасибо.

Оффлайн erezn

  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
Re: Помогите отключить тачпад.
« Ответ #10 : 19 Октябрь 2010, 21:12:29 »
/desktop/gnome/peripherals/touchpad/
на редактирование ключей нет реакции

на
sudo /usr/bin/synclient TouchpadOff=1ответ
Couldn't find synaptics properties. No synaptics driver loaded?
$ xinput list
⎡ Virtual core pointer                     id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer               id=4 [slave  pointer  (2)]
⎜   ↳ ImPS/2 Generic Wheel Mouse               id=15 [slave  pointer  (2)]
⎜   ↳ Macintosh mouse button emulation         id=16 [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=10 [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=12 [slave  pointer  (2)]
⎣ Virtual core keyboard                   id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard             id=5 [slave  keyboard (3)]
    ↳ Power Button                             id=6 [slave  keyboard (3)]
    ↳ Video Bus                               id=7 [slave  keyboard (3)]
    ↳ Power Button                             id=8 [slave  keyboard (3)]
    ↳ Sleep Button                             id=9 [slave  keyboard (3)]
    ↳ HP Webcam-50                             id=13 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard             id=14 [slave  keyboard (3)]
    ↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=11 [slave  keyboard (3)]

И что делать? Ставить synaptics driver?
Ключи в /desktop/gnome/peripherals/touchpad/ для чего нужны, они должны работать?

нетбук - compaq mini 311
« Последнее редактирование: 19 Октябрь 2010, 21:18:11 от erezn »
ubuntu 12.04
fujitsu lifebook p701

Оффлайн erezn

  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
Re: Помогите отключить тачпад.
« Ответ #11 : 25 Октябрь 2010, 12:02:07 »
установил gsynaptics

прописал в /etc/X11/xorg.conf и перегрузился

когда запускаю gsynaptics -

GSynaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics

Что не так делаю?

ниже часть /etc/X11/xorg.conf

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
InputDevice    "Synaptics Touchpad" "SendCoreEvents"
    Option         "Xinerama" "0"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
   Identifier   "Synaptics Touchpad"
   Driver       "synaptics"
   Option       "SendCoreEvents"   "true"
   Option       "Device"   "/dev/psaux"
   Option       "Protocol"   "auto-dev"
   Option       "SHMConfig"   "true"
EndSection

Section "InputDevice"

# generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Пользователь решил продолжить мысль 25 Октябрь 2010, 12:03:33:
$ synclient TouchpadOff=1
Couldn't find synaptics properties. No synaptics driver loaded?
ubuntu 12.04
fujitsu lifebook p701

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.