Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Не переустанавливается GRUB2  (Прочитано 564 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dqopb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Не переустанавливается GRUB2
« : 08 Май 2010, 15:43:33 »
Kubuntu 9.10 была в качестве основной системы.
Затем на некоторое время понадобилась ИксПиха, поставил чип ХР 2010.
Переустановил GRUB2 стандартным способом (с live cd через chroot), при этом update-grub не нашёл винду и не добавил в свой список. Тогда я восстановил загрузку винды через консоль восстановления винды, сделал fixboot и на всякий случай ещё и fixmbr.
Конечно же, граб пропал.

Тогда попытался снова его переустановить:
ubuntu@ubuntu:~$ sudo mount /dev/sda2 /mnt
ubuntu@ubuntu:~$ sudo mount /dev/sda1 /mnt/boot
ubuntu@ubuntu:~$ sudo mount --bind /dev /mnt/dev
ubuntu@ubuntu:~$ sudo chroot /mnt
bash: groups: command not found
root@ubuntu:/#

после этого bash: groups: command not found вход через chroot осуществляется неправильно, и баш не знает команд update-grub, grub-install и других.

Прошу помочь (=
Спасибо за внимание (=

Оффлайн RedBeard

  • Активист
  • *
  • Сообщений: 740
    • Просмотр профиля
Re: Не переустанавливается GRUB2
« Ответ #1 : 08 Май 2010, 15:47:56 »

Оффлайн ABEgorov

  • Участник
  • *
  • Сообщений: 130
    • Просмотр профиля
Re: Не переустанавливается GRUB2
« Ответ #2 : 08 Май 2010, 19:29:14 »
А если попробовать: sudo chroot /mnt /bin/bash

Оффлайн dqopb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Не переустанавливается GRUB2
« Ответ #3 : 10 Май 2010, 17:30:49 »
Вот: http://www.supergrubdisk.org/
Спасибо, но хотелось бы более чётких советов )) А то я чуть нашёл по той ссылке, где можно скачать программу, а потом не смог распаковать (ошибка архива). И что делать с ней - тоже не понимаю )).

Удалось установить граб в обход chroot, при помощи
sudo grub-install --root-directory=/mnt /dev/sdaЗагрузчик работает, но система не загружается. Икс не грузится, и kdm, похоже, тоже. Кидает на первый терминал:
myhost login: mylogin
init: tty1 main process (1268) killed by SEGV signal
init: tty1 main process ended, respawning

Ubuntu 9.10 myhost tty1

myhost login:
Седьмой терминал пустой.

Возможно, проблема с учётными записями, и именно она была изначально, и потому chroot срабатывал неправильно?

 

Страница сгенерирована за 0.071 секунд. Запросов: 22.