Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS  (Прочитано 3419 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dearfear

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Коллеги, прошу помощи Firebird скачанный с оф. сайта не ставится. Нужна именно ветка 1.5

root@dbsrv:/home/dmitriy/firebird# ./install.sh

Firebird super 1.5.6.5026-0.i686 Installation

Press Enter to start installation or ^C to abort
Extracting install data
 System startup links for /etc/init.d/firebird already exist.
Starting Firebird server: start-stop-daemon: Unable to start /opt/firebird/bin/fbmgr.bin: No such file or directory (No such file or directory)

Fixing firebird's shell to /bin/sh

Starting Firebird server: start-stop-daemon: Unable to start /opt/firebird/bin/fbmgr.bin: No such file or directory (No such file or directory)

Please enter new password for SYSDBA user: masterkey


Running ex to modify /etc/init.d/firebird
Install completed

root@dbsrv:/home/dmitriy#
xinetd стоит и запущен. libstdc++5 стоит. firebird2.0-common стоит. libfbclient2 стоит

Оффлайн sergeyvl12

  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #1 : 11 Май 2010, 11:33:54 »
Ты хочешь установить firebird 1.5 но в то же время гордо заявляешь что у тебя "firebird2.0-common стоит. libfbclient2". Уверен что не будет конфликтов?

System startup links for /etc/init.d/firebird already exist.

Думаю что это оно и есть.

Unable to start /opt/firebird/bin/fbmgr.bin: No such file or directory (No such file or directory)

После инсталяции проверь этот файл - нет его действительно?

Думаю что стоит удалить вышеназванные пакеты (firebird2.0-common,libfbclient2) + удалить /etc/init.d/firebird (если не удалится от удаления пакетов) и попытаться проинсталить 1.5 заново.


Оффлайн dearfear

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #2 : 11 Май 2010, 11:55:29 »
Файл, на который он ругается существует. ставил пакеты из ветки 1.5 firebird1.5-common и libfbclient1 всё точно так же. В интернете этот баг описан, ответа пока нет.. :-[
Попробовал с пакетами ветки 1.5 то же самое...
root@dbsrv:/home/dmitriy# dpkg -i /home/dmitriy/Firebird\ server/libfbclient1_1.5.4.4910rel-6_amd64.deb
Выбор ранее не выбранного пакета libfbclient1.
(Чтение базы данных... на данный момент установлено 112654 файлов и каталогов.)
Распаковывается пакет libfbclient1 (из файла .../libfbclient1_1.5.4.4910rel-6_amd64.deb)...
dpkg: зависимости пакетов не позволяют настроить пакет libfbclient1:
 libfbclient1 зависит от firebird1.5-common (= 1.5.4.4910rel-6), однако:
  Пакет firebird1.5-common не установлен.
dpkg: не удалось обработать параметр libfbclient1 (--install):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libfbclient1
root@dbsrv:/home/dmitriy# dpkg -i /home/dmitriy/Firebird\ server/firebird1.5-common_1.5.4.4910rel-6_amd64.deb
Выбор ранее не выбранного пакета firebird1.5-common.
(Чтение базы данных... на данный момент установлено 112661 файлов и каталогов.)
Распаковывается пакет firebird1.5-common (из файла .../firebird1.5-common_1.5.4.4910rel-6_amd64.deb)...
Настраивается пакет firebird1.5-common (1.5.4.4910rel-6) ...
root@dbsrv:/home/dmitriy# dpkg -i /home/dmitriy/Firebird\ server/libfbclient1_1.5.4.4910rel-6_amd64.deb
(Чтение базы данных... на данный момент установлено 112708 файлов и каталогов.)
Подготовка к замене пакета libfbclient1 1.5.4.4910rel-6 (используется файл .../libfbclient1_1.5.4.4910rel-6_amd64.deb)...
Распаковывается замена для пакета libfbclient1 ...
Настраивается пакет libfbclient1 (1.5.4.4910rel-6) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
root@dbsrv:/home/dmitriy# mc
root@dbsrv:/home/dmitriy/firebird# ./install.sh

Firebird super 1.5.6.5026-0.i686 Installation

Press Enter to start installation or ^C to abort
Extracting install data
Archiving...
Done.
Deleting...
Done.
 System startup links for /etc/init.d/firebird already exist.
Starting Firebird server: start-stop-daemon: Unable to start /opt/firebird/bin/fbmgr.bin: No such file or directory (No such file or directory)

Fixing firebird's shell to /bin/sh

Starting Firebird server: start-stop-daemon: Unable to start /opt/firebird/bin/fbmgr.bin: No such file or directory (No such file or directory)

Please enter new password for SYSDBA user: masterkey


Running ex to modify /etc/init.d/firebird
Install completed

root@dbsrv:/home/dmitriy#
« Последнее редактирование: 11 Май 2010, 12:14:21 от dearfear »

Оффлайн sergeyvl12

  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #3 : 11 Май 2010, 12:25:06 »
Попробуй ручками запустить

/opt/firebird/bin/fbmgr.bin

Мне также нужен вывод

file /opt/firebird/bin/fbmgr.bin

,

ldd /opt/firebird/bin/fbmgr.bin

А также версия твоей системы (32 или 64) ?

Оффлайн dearfear

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #4 : 11 Май 2010, 13:08:30 »
dmitriy@dbsrv:~$ sudo /opt/firebird/bin/fbmgr.bin
sudo: unable to execute /opt/firebird/bin/fbmgr.bin: No such file or directory
dmitriy@dbsrv:~$ file /opt/firebird/bin/fbmgr.bin
/opt/firebird/bin/fbmgr.bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.2.5, dynamically linked (uses shared libs), stripped
dmitriy@dbsrv:~$ ldd /opt/firebird/bin/fbmgr.bin
        not a dynamic executable
dmitriy@dbsrv:~$
Ubuntu x64 8.04.4 LTS

Оффлайн sergeyvl12

  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #5 : 11 Май 2010, 13:35:33 »
Знач понятно.

/opt/firebird/bin/fbmgr.bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.2.5, dynamically linked (uses shared libs), stripped

Запуская ./install.sh ты пытаешься установить 32х-битную аппликуху на 64-битную систему. Поэтому этот файл не может быть выполнен (хотя он и есть). Выход у тебя один (если ты хочешь поставить именно эту версию) - используй 32х-битную ось.

Теоретически можно извратиться и поставить все это на 64, но это геморойно.


Оффлайн dearfear

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #6 : 11 Май 2010, 14:12:57 »
Работало на 9.04 x64.... причём особенно не помню что делал. :(  Неужели тупо проблема в архитектуре ?
« Последнее редактирование: 11 Май 2010, 19:23:55 от dearfear »

Оффлайн dj--alex

  • Старожил
  • *
  • Сообщений: 3209
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #7 : 11 Май 2010, 19:38:48 »
пытался ставить Firebird 2.0 целую неделю бился ... даже Постгре при всей своей "вакуумности" все равно лучше.
там хотя бы базу данных создать можно.
а как её тут создавать вообще непонятно.
короче имхо Mysql рулит
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн dearfear

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #8 : 12 Май 2010, 11:15:45 »
Я бы рад уйти на Mysql но увы софт что написан работает только с СУБД Firebird, и только ветки 1.5.
По прежнему прошу помощи.
« Последнее редактирование: 12 Май 2010, 11:18:31 от dearfear »

Оффлайн Yurror

  • Старожил
  • *
  • Сообщений: 1966
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #9 : 12 Май 2010, 12:27:55 »
1) вычистить результаты всех своих эксперементов
2) доустановить 32битные библиотеки?
3) по новой запустить инсталляцию

P.S. я сказал вычистить всё. это означит ни каких упомянаний ни о каких firebird'ах и других компонентов в файловой системе

Оффлайн dearfear

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #10 : 12 Май 2010, 17:54:47 »
Может ли это сделать aptitude ? Если да то как. О каких библиотеках идёт речь ?

Оффлайн sergeyvl12

  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #11 : 12 Май 2010, 18:47:13 »
Для начала надо доустановить ia32-libs (если еще не установлено). Попробуй установить либы, а потом - firebird (только начисто!).

Пользователь решил продолжить мысль 12 Май 2010, 20:17:59:
Вобщем получилось у меня проинсталить его на 10.04 x64.

1. Ставишь ia32-libs;
2. В /usr/lib32 ставишь 32х-битный libstdc++.so.5 http://mirrors.kernel.org/ubuntu/pool/universe/g/gcc-3.3/libstdc++5_3.3.6-17ubuntu1_i386.deb. Я просто распаковал deb и переписал в lib32 две сошки;
3. install.sh
4. Самое главное - после установки переместить некоторые либы из /usr/lib в /usr/lib32 (найдешь их по дате);

При инсталяции будут те же матюги потому что шаг 4 ты еще не выполнил.

По идее все. Все должно работать (у меня нормально запускаются все бинарники из /opt/firebird/bin).

С файрбердом не работал, поэтому более предметно проверить не могу.
« Последнее редактирование: 12 Май 2010, 20:17:59 от sergeyvl12 »

Оффлайн dearfear

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установка Firebird 1.5 i686 под Ubuntu Server 8.04.4 LTS
« Ответ #12 : 13 Май 2010, 10:18:38 »
Даже не знаю парни как Вас всех благодарить. Действительно проблема заключалась именно в недостающих библиотеках ia32-libs. Сервер корректно установился и работает. Искренне желаю Вам успехов в жизни!

 

Страница сгенерирована за 0.063 секунд. Запросов: 25.