Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Ubuntu 9.10 wi-fi сеть есть - интернета нет  (Прочитано 3688 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн LomirDana

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Здравствуйте! Недавно установил себе Ubuntu 9.10 и столкнулся с такой проблемой: Менеджер сетей сразу нашел мою локальную вай фай - попросил пароль и подключился к ней, но интернета нет :( открываю Device network tool там показывают что wlan0 работает нормально и обменивается пакетами и даже реальная скорость итернета есть...а вот ни обновиться ни полазить по сайтам не могу. Подскажите плз как решить проблему - сразу говорю в Ubuntu я полный нуб :) заранее спасибо за помощь
Skype - LomirDana

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #1 : 16 Май 2010, 13:48:09 »
Очень слабое описание проблемы.
Как происходит соединение с инетом? Детально распишите.

Оффлайн LomirDana

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #2 : 16 Май 2010, 14:15:00 »
стоит роутер D-Link 2640U в нем прописано соединение с интернетом, в итоге он раздает инт ернет всем к нему подключившимся - по крайней мере всем на базе Виды. раздает через Вай-фай сеть. на моем ноуте стоит 7ка и Ubuntu параллельно - на 7ке есть интернет на убунте нет. хотя вай фай сеть ловят обе операционки и подключаются к ней. На убунте я делал так: кликал по значку сетевых подключений (в верхнем правом углу) выбирал свою вай-фай сеть . он просил пароль - вводил, мне сообщалось что соединение установлено (Connection Established). после пробовал зайти в инт ернет через мозилу - не открывает сайты, обновление тож не пробивает. открыл настройки соединения вай фай preferences-network connections - wireless там прописал ай-пи и ДНС вручную - тоже не помогло- вернул на автоматик DHCP. Смотрел через Администрирование - сетевые адаптеры, там в сетевой статистике по wlan0  выдавался мой MAC-адрес, скорость соединения с модемом и интернетом (54Мбт/сек и 1Мбт/сек соответственно) в правом столбце показывался объем переданной и принятой информации плюс переданные и принятые пакеты. мало но было принято-передано. на вкладке с пингом - пробовал пинговать по адресу и по ай-пи сайты - просто висло все. Через терминал запрашивал iwconfig - он выводил мне данные о моей вай-фай сети и говорил что вроде все ок. ifconfig тоже показал что устройство работает норм....
Skype - LomirDana

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #3 : 16 Май 2010, 14:18:33 »
Роутер пингуется после соединения?
Открываются ли сайты по IP? google.com (74.125.87.147)
cat /etc/resolv.conf что выдает?

Пользователь решил продолжить мысль 16 Май 2010, 14:20:10:
Какая беспроводная карточка в компьютере?
« Последнее редактирование: 16 Май 2010, 14:20:10 от sht0rm »

Оффлайн LomirDana

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #4 : 16 Май 2010, 15:11:23 »
вот результаты:
lomir@lomir-laptop:~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 195.34.224.1
nameserver 195.34.224.2
nameserver 195.34.224.1
lomir@lomir-laptop:~$ ping -c4 74.125.87.147
PING 74.125.87.147 (74.125.87.147) 56(84) bytes of data.
--- 74.125.87.147 ping statistics --- 4 packets transmitted, 0 received, 100% packet loss, time 3025ms

lomir@lomir-laptop:~$ ping -c4 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=10.3 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=1.71 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=2.06 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=2.09 ms
--- 192.168.1.1 ping statistics --- 4 packets transmitted, 4 received, 0% packet loss, time 3004ms rtt min/avg/max/mdev = 1.716/4.062/10.379/3.650 ms lomir@lomir-laptop:~$ 


А тут привожу результаты iwconfig  и  ifconfig на всякий случай
lomir@lomir-laptop:~$ iwconfig
lo        no wireless extensions.
 
eth0      no wireless extensions.
 
wmx0      no wireless extensions.
 
wmaster0  no wireless extensions.
 
wlan0     IEEE 802.11abgn  ESSID:"LomirDana"   
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:22:B0:C2:ED:EB   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=41/70  Signal level=-69 dBm  Noise level=-91 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
 
pan0      no wireless extensions.
 
lomir@lomir-laptop:~$ 
 



lomir@lomir-laptop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr e0:cb:4e:02:aa:92   
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:31 
 
lo        Link encap:Local Loopback   
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
 
wlan0     Link encap:Ethernet  HWaddr 00:16:eb:17:c8:ee   
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::216:ebff:fe17:c8ee/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1326 (1.3 KB)  TX bytes:7407 (7.4 KB)
 
wmaster0  Link encap:UNSPEC  HWaddr 00-16-EB-17-C8-EE-31-37-00-00-00-00-00-00-00-00   
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
 
wmx0      Link encap:Ethernet  HWaddr 00:1d:e1:13:3c:8b   
          inet addr:192.168.0.155  Mask:255.255.255.0
          UP NOARP  MTU:1400  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:5 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
 
lomir@lomir-laptop:~$ 

P.S. У меня Intel(R) WiFi Link 5150
Skype - LomirDana

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #5 : 16 Май 2010, 16:54:07 »
route покажите еще.

Оффлайн LomirDana

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #6 : 16 Май 2010, 22:31:24 »
вот результаты:
lomir@lomir-laptop:~$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     2      0        0 wlan0
192.168.0.0     *               255.255.255.0   U     1      0        0 wmx0
link-local      *               255.255.0.0     U     1000   0        0 wmx0
 

Skype - LomirDana

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #7 : 16 Май 2010, 22:58:56 »
а что за интерфейс wmx0?

Пользователь решил продолжить мысль 16 Май 2010, 20:59:56:
Нашел, это wimax.

Пользователь решил продолжить мысль 16 Май 2010, 23:01:35:
Попробуйте отключить wmx0
sudo ifconfig wmx0 down
« Последнее редактирование: 16 Май 2010, 23:01:35 от sht0rm »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25946
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #8 : 17 Май 2010, 00:09:44 »
Шторм, у него дефолтного маршрута нет.
Явно сеть ручками (недо)настроена.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #9 : 17 Май 2010, 00:50:09 »
Шторм, у него дефолтного маршрута нет.
Явно сеть ручками (недо)настроена.
Да, действительно.

Оффлайн LomirDana

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #10 : 17 Май 2010, 12:53:40 »
Спасибо за совет про отключение - вечером попробую.

Шторм, у него дефолтного маршрута нет.
Явно сеть ручками (недо)настроена.

А где именно (недо)настроена? на модеме или в ОС? потому как в модеме я вроде бы все прописал.
А как прописывать дефолтный маршрут в Ubuntu я не знаю - как писал в первом посте - только начал знакомство с системой.
Skype - LomirDana

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25946
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #11 : 18 Май 2010, 01:41:23 »
В ОС.
Как настраивал сеть?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн LomirDana

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #12 : 18 Май 2010, 11:56:14 »
стоит роутер D-Link 2640U в нем прописано соединение с интернетом, в итоге он раздает инт ернет всем к нему подключившимся - по крайней мере всем на базе Виды. раздает через Вай-фай сеть. на моем ноуте стоит 7ка и Ubuntu параллельно - на 7ке есть интернет на убунте нет. хотя вай фай сеть ловят обе операционки и подключаются к ней. На убунте я делал так: кликал по значку сетевых подключений (в верхнем правом углу) выбирал свою вай-фай сеть . он просил пароль - вводил, мне сообщалось что соединение установлено (Connection Established). после пробовал зайти в инт ернет через мозилу - не открывает сайты, обновление тож не пробивает. открыл настройки соединения вай фай preferences-network connections - wireless там прописал ай-пи и ДНС вручную - тоже не помогло- вернул на автоматик DHCP. Смотрел через Администрирование - сетевые адаптеры, там в сетевой статистике по wlan0  выдавался мой MAC-адрес, скорость соединения с модемом и интернетом (54Мбт/сек и 1Мбт/сек соответственно) в правом столбце показывался объем переданной и принятой информации плюс переданные и принятые пакеты. мало но было принято-передано. на вкладке с пингом - пробовал пинговать по адресу и по ай-пи сайты - просто висло все. Через терминал запрашивал iwconfig - он выводил мне данные о моей вай-фай сети и говорил что вроде все ок. ifconfig тоже показал что устройство работает норм....

Пользователь решил продолжить мысль 20 Май 2010, 08:56:46:
Видимо запас терпения у ребят истек :( ладно, поробую поковырять еще Ubuntu и полазить еще где нить....
« Последнее редактирование: 20 Май 2010, 08:56:46 от LomirDana »
Skype - LomirDana

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25946
    • Просмотр профиля
Re: Ubuntu 9.10 wi-fi сеть есть - интернета нет
« Ответ #13 : 20 Май 2010, 16:04:14 »
Попробуй отключить ipv6 в мозилле.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.