Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Принтер Canon i-SENSYS LBP2900 не подключается  (Прочитано 3195 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sacred-first

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Всем привет! Друзья, у меня конкретный вопрос. вот устанавливаю я дрова от принтера и провожу следующие за этим манипуляции.....ВСЁ НОРМАЛЬНО.но как только пытаюсь выполнить
sudo /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0
терминал мне отвечает
error while loading shared libraries: libcups.so.2: cannot open shared object file: No such file or directory
Что делать?
Р.S.
по какой бы инструкции дрова не ставил....дохожу до этого шага и теряюсь.........а если всё это игнорировать и провести все шаги до конца,то появляются два принтера (после перезагрузки) canon2900 и canon2900-2 и ни один не печатает.........в заданиях написано, что идёт обработка и всё.....
P.S.№2
я уж хотел и через эмулятор virtualbox и установленную винду наладить печать, только вот и там для меня облом - пишет про принтер (при выборе подключаемых устройств в свойствах) "не доступно"
Как вообще заставить этот принтер печатать? Помогите!я новичок в ubuntu! SOS! НИ ОДНУ УЖЕ НЕДЕЛЮ УЖЕ БЬЮСЬ!

Версии системы Ubuntu 8.04 и 10.04
« Последнее редактирование: 13 Июнь 2016, 16:26:56 от Пользователь »

Оффлайн Messia

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
« Последнее редактирование: 17 Май 2010, 10:42:01 от Messia »

Оффлайн sacred-first

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
А вот так?
http://itshaman.ru/articles/98/kak-ustanovit-printer-canon-lbp-2900-v-linux-ubuntu
Только что запустил по ней...

ну вот например по этой этой инструкции я дойду до шага семь и у меня вылезет обозначенное в предыдущем сообщении ошибка


Пользователь решил продолжить мысль 17 Май 2010, 11:27:42:
сейчас вот на Ubuntu 8.04 пытался поставить этот драйвер по инструкции из темы "принтер canon LBP-2900 i-sensys не печатает" автора "menfis";
"1. Принтер отключен, включить компьютер.

2. Подготавливаем для установки принтера пакеты:
  $ sudo apt-get install libxml1 libpng12-0 libpng12-dev libgtk1.2 libgtk1.2-common

3. Драйвера скачать, распаковать, установить http://software.canon-europe.com/products/0010177.asp  (если есть в локальном репозитарии, то уже, скорее всего установлены):

cndrvcups-common_1.60-1_i386.deb
cndrvcups-capt_1.60-1_i386.deb

4.Разрешаем доступ всем
$ sudo chmod 777 /var/ccpd/fifo0

Переходим в /usr/share/ppd/ и создаём ссылки
$ cd /usr/share/ppd/
$ sudo ln -s /usr/share/cups/model/CNCUPSLBP2900CAPTK.ppd
                                                       
Регистрируем принтер в системе
$sudo /usr/sbin/lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E

Регистрируем принтер в cppd
$ sudo /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0

Добавляем скрипт в автозагрузку
$ sudo update-rc.d ccpd defaults 20

Включаем принтер и делаем доступным
 $ sudo chmod 777 /dev/usb/lp0

перезагружаем компьютер."


Дохожу до "Регистрируем принтер в cppd" и у меня вылезает

sudo: unable to execute /usr/sbin/ccpdadmin: No such file or directory

Что делать не знаю/   Я НОВИЧОК/ МОГУ ЧТО-ТО НЕ ПОНИМАТЬ/ ПОМОГИТЕ!
« Последнее редактирование: 17 Май 2010, 11:27:42 от sacred-first »

Оффлайн starper

  • Новичок
  • *
  • Сообщений: 21
  • Ну и ну...
    • Просмотр профиля
    • "Сторожка"
Только что, вчера, установил LBP2900 на  Mint 9 Isadora. Точно так же ставил его ранее на Ubuntu 9.10. Привожу не описание, а документирование установки, т.е. описание в реальном времени (выполнил команду - записал результат). Поскольку тема поднималась в форуме неоднократно, да и сам я не любитель множить сущности без меры, засовываю всё под спойлер, добавив минимальные комментарии.

   
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 18 Май 2010, 16:24:03 от starper »
Дна нет, есть препятствие на пути вглубь. С. Е. Лец

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
установку этого принтера 10.04 делал по этой инструкции:
https://forum.ubuntu.ru/index.php?topic=56078.msg564464#msg564464
предварительно пересобрав пакет cndrvcups-common.
вот пересборка на примере пакета для  х64:

dpkg-deb -x cndrvcups-common_1.80-1_amd64.deb commonполучаем папку common
dpkg-deb --control cndrvcups-common_1.80-1_amd64.debполучаем папку DEBIAN

Заходим в common и в файле control меняем  libcupsys2 на libcups2
после перемещаем папку  DEBIAN в common
и выполняем
dpkg -b common new_cndrvcups-common_1.80-1_amd64.deb
получаем пакет new_cndrvcups-common_1.80-1_amd64.deb.
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн sacred-first

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
ну вот пытался я это делать по инструкции starper.........
только дохожу до
sudo /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0
он мне выдаёт error while loading shared libraries: libcups.so.2: cannot open shared object file: No such file or directory
дрова брал со страницы нашего форума самой свежей версии для amd64                  https://forum.ubuntu.ru/index.php?topic=97395.0


и чё делать теперь? :idiot2:

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
А у тебя все пакеты установлены?  проверь, стоит ли libcups2, если да, то попробуй переустановить его.
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн sacred-first

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Конечно нет :) щас попробую 8)спасибо за совет

Пользователь решил продолжить мысль 31 Май 2010, 19:38:18:
слушай, а если по инструкции starper а делать, не помнишь команды, чтобы архитектуру 386 игнорировать при установке?

Пользователь решил продолжить мысль 31 Май 2010, 21:39:05:
в смысле при установке драйверов :idiot2:
« Последнее редактирование: 31 Май 2010, 21:39:05 от sacred-first »

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
dpkg --force-architecture -i *.deb
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн sacred-first

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
короче, я этот пакет не ставил.......а поставить не могу - ссылку не найду? :idiot2:

Пользователь решил продолжить мысль 31 Май 2010, 19:51:12:
за команду спасибо! ;)

Пользователь решил продолжить мысль 31 Май 2010, 21:51:56:
пакет от karmic не подходит

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
а почему libcups2 через synaptic не поставить?
пакет для x64 я брал с https://help.ubuntu.com/community/HardwareSupportComponentsPrinters/CanonPrinters/Canon_LBP_2900

Там в инструкции, в разделе для 64-битных систем есть ссылки на 64 битные дрова для него.
Только cndrvcups-common надо будет пересобрать.
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

 

Страница сгенерирована за 0.066 секунд. Запросов: 24.