Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: ATI linux driver 8.7  (Прочитано 2246 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн max4it

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
ATI linux driver 8.7
« : 19 Май 2010, 14:59:22 »
Прошу помочь мне в установке ATI linux driver 8.7... Потому как я "чайник" :idiot2: .У меня стоит LinuxMint на основе ubuntu Ядро Linux 2.6.28-11-generic.Прошу подробно мне описать как установить  ATI linux driver 8.7 , и очень популярно  :coolsmiley:.
ati-driver-installer-8-7-x86.x86_64.run Это название установочного фала драйвера)

Оффлайн s†ranger

  • Активист
  • *
  • Сообщений: 319
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #1 : 19 Май 2010, 15:09:46 »
Положить файл в домашнюю директорию, затем открыть консоль и ввести
sudo sh ati-driver-installer-8-7-x86.x86_64.run

Оффлайн max4it

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #2 : 19 Май 2010, 15:11:29 »
Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.28-11-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.PYnfQo

вот в самом концe...

Пользователь решил продолжить мысль 19 Май 2010, 11:30:24:
У меня видеокарта ATI Mobility Radeon X2300  мб кто поможет =\

« Последнее редактирование: 19 Май 2010, 15:45:48 от max4it »

Оффлайн VolCh

  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #3 : 19 Май 2010, 16:19:34 »
По-моему эти дрова для этой видяхи не подойдут

Оффлайн max4it

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #4 : 19 Май 2010, 16:39:33 »
По-моему эти дрова для этой видяхи не подойдут
Мм ,тогда какой надо драйвер для моей видеокарты?! Я немогу найти подходящий... Ежели кто знает прошу дать ссылку.

Оффлайн VolCh

  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #5 : 19 Май 2010, 17:02:01 »
Должны были встать "из коробки"

Оффлайн sander-007

  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #6 : 19 Май 2010, 17:45:25 »
Не должны они вставать из каробки. Нужно с сайта АМД скачать драйвер версии минимум 9.10 а можно и новые и установить как написал товарищ stranger. А если у Вас в меню Администрирование есть пункт Драйвера то попробовать установить с помощью этой утилиты. если ее нет то установить самому sudo apt-get install jockey-gtk. Она как раз с репов убунты тянет последние стабильные версии дров. У мня по крайней мере так Радеон HD 2400.

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
Re: ATI linux driver 8.7
« Ответ #7 : 19 Май 2010, 17:47:50 »
дрова древнее мамонта, качай новые с сайта ATI 10.* и ставь по мануалу
http://help.ubuntu.ru/wiki/%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80%D0%B0_ati

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5083
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #8 : 19 Май 2010, 18:24:40 »
Под вашу карту дров от ати нет
поскольку видеокарта является чудо поделием производителя ноута, так, что вопросы по работоспособным драйверам задайте в тех поддержку
но видимо это будет тщетно

Оффлайн max4it

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #9 : 19 Май 2010, 20:22:52 »
дрова древнее мамонта, качай новые с сайта ATI 10.* и ставь по мануалу
http://help.ubuntu.ru/wiki/%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80%D0%B0_ati
Сделал все как вы сказали скачал "ati-driver-installer-10-4-x86.x86_64.run" начал установку по мануалу и столкнулся с проблемой...
При установке "ati-driver-installer-10-4-x86.x86_64.run" по мануалу:. Создание .deb пакетов

На момент обновления статьи последняя версия Catalyst была 10.3, а последняя версия Ubuntu - 9.10, но вам нисколько это не помешает воспользоваться данным руководством для более ранних или поздних версий Catalyst или Ubuntu, всего лишь замените встречающиеся ниже «ati-driver-installer-10-3-x86.x86_64.run», на имя скаченного вами файла, а любое упоминание Ubuntu/karmic на Ubuntu/<номер версии вашего дистрибутива Ubuntu> (например, Ubuntu/8.04 или Ubuntu/10.04 и т.д.)
Чтобы создать пакеты для вашего дистрибутива перейдите в домашнюю папку (либо в ту папку, куда вы загрузили Catalyst на предыдущем шаге) и запустите команду:
sh ati-driver-installer-10-4-x86.x86_64.run --buildpkg Ubuntu/karmic  вот тут настигла меня проблема , в постах выше сказано что надо устанавливать так "sudo sh  ati-driver-installer-10-4-x86.x86_64.run" а в мануале указано подругому...Я пробывал так "sudo sh  ati-driver-installer-10-4-x86.x86_64.run" вот ход установки:

sudo sh ati-driver-installer-10-4-x86.x86_64.run
Created directory fglrx-install.rCOwIJ
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.723......................

================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: i686 (32-bit)
X Server: X.Org 7.4
Removing temporary directory: fglrx-install.rCOwIJ.


После чего я последовал дальше по мануалу.
4. Установка пакетов и активация драйвера

Созданные .deb пакеты будут находиться в той же директории, что и скаченный нами пакет catalyst. Чтобы установить их введите в терминале следующую команду:

sudo dpkg -i *.deb.dpkg: не удалось обработать параметр *.deb (--install):
 нет доступа к архиву: No such file or directory
При обработке следующих пакетов произошли ошибки:
 *.deb
.


В этом варианте  "sh ati-driver-installer-10-4-x86.x86_64.run --buildpkg Ubuntu/karmic" закончилось все гораздо раньше...

sh ati-driver-installer-10-4-x86.x86_64.run --buildpkg Ubuntu/karmic
Created directory fglrx-install.zfluON
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.723....



==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: Ubuntu/karmic
Resolving build dependencies...
Unable to resolve  execstack.  Please manually install and try again.
Package build failed!
Package build utility output:
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 2:8.723-0ubuntu1
dpkg-buildpackage: source changed by ATI Technologies Inc. <http://ati.amd.com/support/driver.html>
 debian/rules build
dpkg-buildpackage: host architecture i386
test -x debian/rules
mkdir -p "."
#Create important strings
for i in 10fglrx \
          dkms.conf \
          xorg-driver-fglrx.install \
          xorg-driver-fglrx-dev.install \
          fglrx-kernel-source.install \
          fglrx-amdcccle.install \
          libamdxvba1.install \
          overrides/fglrx-kernel-source; do \
      sed -e "s|#XMODDIR#|usr/lib/xorg/modules|"     \
         -e "s|#XMODDIR32#||" \
         -e "s|#DRIDIR32#|usr/lib32|"   \
         -e "s|#LIBDIR#|lib|"       \
         -e "s|#DRIDIR#|usr/lib|"       \
         -e "s|#CVERSION#|8.723|"   \
         -e "s|#XARCH#|x740|"   \
         -e "s|#ARCH#|x86|"   \
         debian/$i.in > debian/$i;      \
   done
# remove exec bit on everything
find arch \
      etc \
      lib \
      module \
      usr \
      x740     -type f | xargs chmod -x
find: `module': No such file or directory
# set executable on user apps
find arch/x86/usr/sbin \
      arch/x86/usr/X11R6/bin \
      usr/sbin/ -type f | xargs chmod a+x
# set exec bit on scripts
find lib etc debian -name "*.sh" -type f | xargs chmod +x
# Generate modaliases
sh -e debian/modaliases/fglrx_supported \
      lib/modules/fglrx/build_mod/fglrxko_pci_ids.h > \
      debian/modaliases/fglrx-modules.alias.override
 debian/rules binary
test -x debian/rules
dh_testroot
dh_clean -k
dh_installdirs -A
mkdir -p "."
#Create important strings
for i in 10fglrx \
          dkms.conf \
          xorg-driver-fglrx.install \
          xorg-driver-fglrx-dev.install \
          fglrx-kernel-source.install \
          fglrx-amdcccle.install \
          libamdxvba1.install \
          overrides/fglrx-kernel-source; do \
      sed -e "s|#XMODDIR#|usr/lib/xorg/modules|"     \
         -e "s|#XMODDIR32#||" \
         -e "s|#DRIDIR32#|usr/lib32|"   \
         -e "s|#LIBDIR#|lib|"       \
         -e "s|#DRIDIR#|usr/lib|"       \
         -e "s|#CVERSION#|8.723|"   \
         -e "s|#XARCH#|x740|"   \
         -e "s|#ARCH#|x86|"   \
         debian/$i.in > debian/$i;      \
   done
# remove exec bit on everything
find arch \
      etc \
      lib \
      module \
      usr \
      x740     -type f | xargs chmod -x
find: `module': No such file or directory
# set executable on user apps
find arch/x86/usr/sbin \
      arch/x86/usr/X11R6/bin \
      usr/sbin/ -type f | xargs chmod a+x
# set exec bit on scripts
find lib etc debian -name "*.sh" -type f | xargs chmod +x
# Generate modaliases
sh -e debian/modaliases/fglrx_supported \
      lib/modules/fglrx/build_mod/fglrxko_pci_ids.h > \
      debian/modaliases/fglrx-modules.alias.override
dh_installdirs -pxorg-driver-fglrx
dh_installdirs -pxorg-driver-fglrx-dev
dh_installdirs -pfglrx-kernel-source
dh_installdirs -pfglrx-amdcccle
dh_installdirs -pfglrx-modaliases
dh_installdirs -plibamdxvba1
dh_installdocs -pxorg-driver-fglrx  
dh_installexamples -pxorg-driver-fglrx
dh_installman -pxorg-driver-fglrx  
dh_installinfo -pxorg-driver-fglrx  
dh_installmenu -pxorg-driver-fglrx
dh_installcron -pxorg-driver-fglrx
dh_installinit -pxorg-driver-fglrx  
dh_installdebconf -pxorg-driver-fglrx
dh_installemacsen -pxorg-driver-fglrx  
dh_installcatalogs -pxorg-driver-fglrx
dh_installpam -pxorg-driver-fglrx
dh_installlogrotate -pxorg-driver-fglrx
dh_installlogcheck -pxorg-driver-fglrx
dh_installchangelogs -pxorg-driver-fglrx  
dh_installudev -pxorg-driver-fglrx
dh_lintian -pxorg-driver-fglrx
dh_install -pxorg-driver-fglrx  
dh_link -pxorg-driver-fglrx  
dh_installmime -pxorg-driver-fglrx
#they don't provide the symlink for us (starting at 8.699)
dh_link -pxorg-driver-fglrx usr/lib/libatiuki.so.1.0 usr/lib/libatiuki.so.1
#they don't provide the symlink for us (starting at 8.72)
dh_link -pxorg-driver-fglrx usr/lib/libfglrx_gamma.so.1.0 usr/lib/libfglrx_gamma.so.1
dh_installdocs -pxorg-driver-fglrx usr/share/doc/fglrx/* --exclude ATI_LICENSE.TXT
dh_installinit -pxorg-driver-fglrx --name="atieventsd" --no-start --update-rcd-params="defaults 31"
for i in \
         debian/xorg-driver-fglrx/usr/bin/atiode \
         debian/xorg-driver-fglrx/usr/sbin/amdnotifyui \
         debian/xorg-driver-fglrx/usr/lib/dri/fglrx_dri.so \
         debian/xorg-driver-fglrx/usr/lib/libGL.so.* \
         ; do execstack -q $i; execstack -c $i; done
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
make: *** [binary-install/xorg-driver-fglrx] Error 127
dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 2:8.723-0ubuntu1
dpkg-buildpackage: source changed by ATI Technologies Inc. <http://ati.amd.com/support/driver.html>
 debian/rules build
dpkg-buildpackage: host architecture i386
test -x debian/rules
mkdir -p "."
#Create important strings
for i in 10fglrx \
          dkms.conf \
          xorg-driver-fglrx.install \
          xorg-driver-fglrx-dev.install \
          fglrx-kernel-source.install \
          fglrx-amdcccle.install \
          libamdxvba1.install \
          overrides/fglrx-kernel-source; do \
      sed -e "s|#XMODDIR#|usr/lib/xorg/modules|"     \
         -e "s|#XMODDIR32#||" \
         -e "s|#DRIDIR32#|usr/lib32|"   \
         -e "s|#LIBDIR#|lib|"       \
         -e "s|#DRIDIR#|usr/lib|"       \
         -e "s|#CVERSION#|8.723|"   \
         -e "s|#XARCH#|x740|"   \
         -e "s|#ARCH#|x86|"   \
         debian/$i.in > debian/$i;      \
   done
# remove exec bit on everything
find arch \
      etc \
      lib \
      module \
      usr \
      x740     -type f | xargs chmod -x
find: `module': No such file or directory
# set executable on user apps
find arch/x86/usr/sbin \
      arch/x86/usr/X11R6/bin \
      usr/sbin/ -type f | xargs chmod a+x
# set exec bit on scripts
find lib etc debian -name "*.sh" -type f | xargs chmod +x
# Generate modaliases
sh -e debian/modaliases/fglrx_supported \
      lib/modules/fglrx/build_mod/fglrxko_pci_ids.h > \
      debian/modaliases/fglrx-modules.alias.override
 debian/rules binary
test -x debian/rules
dh_testroot
dh_clean -k
dh_installdirs -A
mkdir -p "."
#Create important strings
for i in 10fglrx \
          dkms.conf \
          xorg-driver-fglrx.install \
          xorg-driver-fglrx-dev.install \
          fglrx-kernel-source.install \
          fglrx-amdcccle.install \
          libamdxvba1.install \
          overrides/fglrx-kernel-source; do \
      sed -e "s|#XMODDIR#|usr/lib/xorg/modules|"     \
         -e "s|#XMODDIR32#||" \
         -e "s|#DRIDIR32#|usr/lib32|"   \
         -e "s|#LIBDIR#|lib|"       \
         -e "s|#DRIDIR#|usr/lib|"       \
         -e "s|#CVERSION#|8.723|"   \
         -e "s|#XARCH#|x740|"   \
         -e "s|#ARCH#|x86|"   \
         debian/$i.in > debian/$i;      \
   done
# remove exec bit on everything
find arch \
      etc \
      lib \
      module \
      usr \
      x740     -type f | xargs chmod -x
find: `module': No such file or directory
# set executable on user apps
find arch/x86/usr/sbin \
      arch/x86/usr/X11R6/bin \
      usr/sbin/ -type f | xargs chmod a+x
# set exec bit on scripts
find lib etc debian -name "*.sh" -type f | xargs chmod +x
# Generate modaliases
sh -e debian/modaliases/fglrx_supported \
      lib/modules/fglrx/build_mod/fglrxko_pci_ids.h > \
      debian/modaliases/fglrx-modules.alias.override
dh_installdirs -pxorg-driver-fglrx
dh_installdirs -pxorg-driver-fglrx-dev
dh_installdirs -pfglrx-kernel-source
dh_installdirs -pfglrx-amdcccle
dh_installdirs -pfglrx-modaliases
dh_installdirs -plibamdxvba1
dh_installdocs -pxorg-driver-fglrx  
dh_installexamples -pxorg-driver-fglrx
dh_installman -pxorg-driver-fglrx  
dh_installinfo -pxorg-driver-fglrx  
dh_installmenu -pxorg-driver-fglrx
dh_installcron -pxorg-driver-fglrx
dh_installinit -pxorg-driver-fglrx  
dh_installdebconf -pxorg-driver-fglrx
dh_installemacsen -pxorg-driver-fglrx  
dh_installcatalogs -pxorg-driver-fglrx
dh_installpam -pxorg-driver-fglrx
dh_installlogrotate -pxorg-driver-fglrx
dh_installlogcheck -pxorg-driver-fglrx
dh_installchangelogs -pxorg-driver-fglrx  
dh_installudev -pxorg-driver-fglrx
dh_lintian -pxorg-driver-fglrx
dh_install -pxorg-driver-fglrx  
dh_link -pxorg-driver-fglrx  
dh_installmime -pxorg-driver-fglrx
#they don't provide the symlink for us (starting at 8.699)
dh_link -pxorg-driver-fglrx usr/lib/libatiuki.so.1.0 usr/lib/libatiuki.so.1
#they don't provide the symlink for us (starting at 8.72)
dh_link -pxorg-driver-fglrx usr/lib/libfglrx_gamma.so.1.0 usr/lib/libfglrx_gamma.so.1
dh_installdocs -pxorg-driver-fglrx usr/share/doc/fglrx/* --exclude ATI_LICENSE.TXT
dh_installinit -pxorg-driver-fglrx --name="atieventsd" --no-start --update-rcd-params="defaults 31"
for i in \
         debian/xorg-driver-fglrx/usr/bin/atiode \
         debian/xorg-driver-fglrx/usr/sbin/amdnotifyui \
         debian/xorg-driver-fglrx/usr/lib/dri/fglrx_dri.so \
         debian/xorg-driver-fglrx/usr/lib/libGL.so.* \
         ; do execstack -q $i; execstack -c $i; done
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
make: *** [binary-install/xorg-driver-fglrx] Error 127
dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
Removing temporary directory: fglrx-install.zfluON


И у меня назрел вопрос товарищи , что мне делать?)  :'(


« Последнее редактирование: 19 Май 2010, 20:25:18 от max4it »

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5083
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #10 : 19 Май 2010, 20:29:38 »
Я бы вам посоветовал по меньше читать не подходящие мануалы, а следовать рекомендации производителя т.е. скачать мануальчик с ати там же где и драйвер
но напомню, что ати не выпускает драйверов под вашу видеокарту, но возможно повезёт и она заработает



по окончанию установки используем команду описанную в мануале
либо
sudo aticonfig --initial -f
перезагружаем ПК

Пользователь решил продолжить мысль 19 Май 2010, 20:40:59:
Забыл сказать жать надо на инстал драйвер т.е. всё автоматом ни каких сборок пакетов не нужно
« Последнее редактирование: 19 Май 2010, 20:40:59 от gregory5 »

Оффлайн max4it

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #11 : 19 Май 2010, 20:51:18 »
Я бы вам посоветовал по меньше читать не подходящие мануалы, а следовать рекомендации производителя т.е. скачать мануальчик с ати там же где и драйвер
но напомню, что ати не выпускает драйверов под вашу видеокарту, но возможно повезёт и она заработает



по окончанию установки используем команду описанную в мануале
либо
sudo aticonfig --initial -f
перезагружаем ПК

Пользователь решил продолжить мысль 19 Май 2010, 18:40:59:
Забыл сказать жать надо на инстал драйвер т.е. всё автоматом ни каких сборок пакетов не нужно
А как мне потом определить работает оно или нет?

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5083
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #12 : 19 Май 2010, 20:53:58 »
до перезагрузки никак, потому, что с ядром драйвер начнёт работать только после
если не запуститься то прийдётся удалить вместе с xorg.conf
как удалить в мануале я не помню но вроде должно написано быть

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
Re: ATI linux driver 8.7
« Ответ #13 : 19 Май 2010, 20:57:12 »
если система загрузится и если сможешь эффекты компиз включить, значит работает


p/s gregory5 ну раз мануал считаешь "левым", так перепиши его, и скрины добавь из мануала с сайта ATI, а лучше свои собственные сделай
p/s/s мануал бы давно и сам переписал, но атишной видюхи под рукой нет

Оффлайн max4it

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: ATI linux driver 8.7
« Ответ #14 : 19 Май 2010, 21:00:42 »
если система загрузится и если сможешь эффекты компиз включить, значит работает


p/s gregory5 ну раз мануал считаешь "левым", так перепиши его, и скрины добавь из мануала с сайта ATI, а лучше свои собственные сделай
p/s/s мануал бы давно и сам переписал, но атишной видюхи под рукой нет
что по твоему "компиз эффекты"?:) поясни

 

Страница сгенерирована за 0.076 секунд. Запросов: 22.