Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Даунгрейд PHP -как сделать быстро? и какая переменная покажет Zend optimizer ус?  (Прочитано 3726 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dj--alex

  • Автор темы
  • Старожил
  • *
  • Сообщений: 3209
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
У меня другая проблема Php 5.3 i Zend Optimizer 3.3.9 не совместимы
как даунгрейдить грамотно php   (желательно через synaptic) так чтобы от него ничего не отвалилось и он от апача не отвалился?
нужна версия 5.2 и никаких свистоплясок с сорцами.

http://dj.chg.su/dbscript/index.php/how-to-zend.html
скачать можете там же

и подскажите какая переменная в php отвечает за информацию о Zend optimizer i zend optimization level
обращались не раз пользователи с неправильно настроенным зендом.
хотелось бы вписать в программу таковую проверку. чтобы она сама выдавала рекомендацию.
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн optimizmo

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Думаю, что ещё актуально, поэтому отпишу метод, которым у меня получилось. Проблема была аналогичная, Zend Optimizer 3.3.9 отказался работать с php 5.3. Никакие ухищрения по ручной установке из описанных здесь на форуме не привели к появлению инициалов оптимайзера в phpinfo(). Пришлось делать откат на php 5.2.
Самым безболезненным способом получилось так.
Открываем список репозиториев:
sudo gedit /etc/apt/sources.listДобавляем туда ссылку на репозиторий от предыдущей версии:

deb http://archive.ubuntu.com/ubuntu jaunty main restricted universe multiverse #old version (!)

Запускаем Symantec и обновляем списки пакетов. Поскольку мы добавили старый репозиторий, то в списке пакетов станут доступны старые версии некоторых пакетов. Чтобы их выбрать, выделяем пакет, заходим: "Главное Меню -> Пакет -> Указать версию..." . Находим пакеты php5-common и libapache2-mod-php5 и каждому из них ставим версию 5.2.
Устанавливаем. В процессе установки Synaptic, по идее, должен спросить, что делать со существующими файлами конфигурации php.ini и т.п.. Если я оставлял старые версии, то Apache не запускался вообще, поэтому, видимо, лучше сделать резервную копию перезаписать эти файлы и потом заново вручную восстановить нужные настройки.
После этого, если Zend Optimizer был установлен ручным методом по официальной инструкции от Zend'a, то он должен работать.
« Последнее редактирование: 03 Июль 2010, 16:01:18 от optimizmo »

Оффлайн dj--alex

  • Автор темы
  • Старожил
  • *
  • Сообщений: 3209
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
Спасибо оргомное , реально помогло , теперь зенд пашет!!!

правда задолбался указывать не обновлять модули с 5.2.6 на 5.3 
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн smalish

  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Цитировать
Запускаем Symantec и обновляем списки пакетов. Поскольку мы добавили старый репозиторий, то в списке пакетов станут доступны старые версии некоторых пакетов. Чтобы их выбрать, выделяем пакет, заходим: "Главное Меню -> Пакет -> Указать версию..." . Находим пакеты php5-common и libapache2-mod-php5 и каждому из них ставим версию 5.2.
Устанавливаем. В процессе установки Synaptic, по идее, должен спросить, что делать со существующими файлами конфигурации php.ini и т.п.. Если я оставлял старые версии, то Apache не запускался вообще, поэтому, видимо, лучше сделать резервную копию перезаписать эти файлы и потом заново вручную восстановить нужные настройки.

А как сделать это через терминал?
« Последнее редактирование: 28 Сентябрь 2010, 00:35:47 от smalish »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25957
    • Просмотр профиля
Не надо редактировать sources.list
sudo -E -s
echo "deb http://archive.ubuntu.com/ubuntu jaunty main restricted universe multiverse" > /etc/apt/sources.list.d/jaunty.list
apt-get update

Но!
Это угробит вам основные пакеты с некоторой вероятностью.
Так что лучше всего СНАЧАЛА обновить систему, ПОТОМ сделать имплантацию, поставить ТОЛЬКО php, вернуть всё взад (удалить файл/закомментить строку в файле).
И захолдить пакет.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн thunderamur

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6747
  • Ubuntu 16.04
    • Просмотр профиля
Самый правильный способ отката:

https://forum.ubuntu.ru/index.php?topic=52552.0
п.7

Оффлайн smalish

  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
В предложенном посте есть пункт:
Цитировать
gksu gedit /etc/apt/preferences.d/php
Не получилось, т.к. во-первых у меня нет графической оболочки, чтобы выполнить команду gedit и во-вторых я не понимаю, что такое preferences.d/php - файл без расширения?
Далее система отругалась на команду:
Цитировать
sudo apt-get purge php*
похоже, ей не понравилась "звездочка"...

Оффлайн thunderamur

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6747
  • Ubuntu 16.04
    • Просмотр профиля
предлагаю тот топик обсуждать там же, а то фигня какая-то получается.

https://forum.ubuntu.ru/index.php?topic=52552.msg855690#msg855690

 

Страница сгенерирована за 0.074 секунд. Запросов: 22.