Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: как переставить более новую версию программы на более старую  (Прочитано 622 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн demon999

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Необходимо удалить php5.3 и все зависимости и поставить php5.2 со всеми зависимостями. Как это сделать в консоли? :)
точно не помнишь, сам не  пробовал, но по твоему точно знаешь как?! Лучше не советуй. Google не заменит человека.

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5108
    • Просмотр профиля
1. Удалить версию 5.3
2. Выяснить, какие зависимости у версии 5.2, скачать в один каталог и попробовать -
3. Установить все пакеты командой
sudo dpkg -i *.deb

Оффлайн wl

  • Старожил
  • *
  • Сообщений: 1393
    • Просмотр профиля
Что-то типа
$ sudo aptitude install php5=5.2.10
Цитата: man aptitude
To select a particular version of the package, append “=<version>” to the package name: for instance,
“aptitude install apt=0.3.1”. Similarly, to select a package from a particular archive, append “/<archive>” to
 the package name: for instance, “aptitude install apt/experimental”.

Да, с удалением 5.3, думаю, сами справитесь. :)
На свете феньки есть такие, брат Горацио, которых лохи просто не секут. (Шекспир, "Гамлет", вольный перевод)

Оффлайн enfernal

  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
Зайди в синаптик,найти необходимый пакет,нажать меню>пакет,выбрать пункт,указать версию...

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.