Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: VPN не подключается автоматически  (Прочитано 637 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн McDanger

  • Автор темы
  • Любитель
  • *
  • Сообщений: 84
    • Просмотр профиля
Всем привет. Хочу что-бы VPN подключался автоматически при старте системы. Прописал команду pon vpn в /etc/rc.local, не стартует. При этом вручную, после загрузки системы, все работает как надо. Заморачиваться с написанием скрипта лень. Да и нафиг он нужен если rc.local и так стартует последним из сценариев. Или я что-то недопонимаю или у Ubuntu что-то где-то еще нужно прописывать. Вот сам rc.local (Думаю нового вы тут не увидите). Система Uduntu 10.4

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
pon vpn
exit 0

Оффлайн s†ranger

  • Активист
  • *
  • Сообщений: 319
    • Просмотр профиля
Re: VPN не подключается автоматически
« Ответ #1 : 24 Мая 2010, 21:59:27 »
Может, попробовать sleep 10 && pon vpn

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28376
    • Просмотр профиля
Re: VPN не подключается автоматически
« Ответ #2 : 24 Мая 2010, 22:28:02 »
Всем привет. Хочу что-бы VPN подключался автоматически при старте системы.

Пропиши его в /etc/network/interfaces
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.031 секунд. Запросов: 23.