Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Не запускается винда после установки Ubuntu  (Прочитано 2966 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Maagog

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Здравствуйте.
Поставил Ubuntu себе на ноутбук, создал раздел, установил область подкачки. Вообщем, ничего не предвещало беды.
Собственно, при выборе Windows при загрузке появляется ошибка - "Не удается запустить Windows из-за  аппаратных ошибок настройки диска. Не удается выполнить чтение с выбранного загрузочного диска."
Содержимое файла boot.ini - [boot loader]
timeout=30
default=signature(a33b6c03)disk(0)rdisk(0)partition(1)WINDOWS
[operating systems]
signature(a33b6c03)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional RU" /execute /fastdetect
менял значение partition на (2),- при загрузке появляется выбор - Microsoft Windows XP Professional RU или windows по умолчанию, но опять та ошибка :(

Скриншот разделов винчестера в стандартной утилите Ubuntu:

http://i49.tinypic.com/2mh60w2.png

ext4 - раздел, куда установлена Ubuntu; 2.9 - область подкачки.

Спасибо.

Пользователь решил продолжить мысль 26 Май 2010, 23:01:23:
up
« Последнее редактирование: 26 Май 2010, 23:01:23 от Maagog »

Оффлайн byte916

  • Участник
  • *
  • Сообщений: 185
    • Просмотр профиля
У вас винда на какой раздел установлена?
Ubuntu 14.04 + MATE

Оффлайн Maagog

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Винда установлена на раздел Nick (31GB ntfs).
 До установки Ubuntu было 3 диска - 1)Где стоит винда
2)60гб. Из него я создал раздел 40гб, куда поставил Ubuntu и 2гб - область подкачки.
3)66гб - с ним ничего не делал.

Оффлайн byte916

  • Участник
  • *
  • Сообщений: 185
    • Просмотр профиля
Проверьте на ошибки раздел на котором винда, если не поможет, то переустановите её, и затем с live-cd восстановите grub.
а еще лучше - решить нужна ли вам отдельно установленная винда, или проще будет поставить её в эмулятор, или пользовать wine
Ubuntu 14.04 + MATE

Оффлайн flash1

  • Участник
  • *
  • Сообщений: 131
  • city cat
    • Просмотр профиля
Maagog

Меня лично смущает значение signature(a33b6c03) в Вашем boot.ini  ???, должно быть вот это multi(0) или аналогичное, т.е. меняется цифра в зависимости от того на каком именно разделе установлена Windows, и вроде бы в обеих строках перед словом WINDOWS (сразу после partition(1)) должен быть слеш, т.е. \WINDOWS  ???...
« Последнее редактирование: 27 Май 2010, 15:11:29 от flash1 »
Debian 6 Squeeze (work-home), Windows 2003 R2 SP2 Enterprise (work-home).

Оффлайн Maagog

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Спасибо за помощь.
byte916, на ошибки проверю. sudo fsck, предварительно отмонтировав диск?
Не использовать винду пока не представляется возможным - нужен visual studio для курсовой :)

flash1
Изменил на multi(1) - появился выбор Microsoft Windows XP Professional RU и windows по умолчанию, но все также ошибка.

Вообще, я допустил ошибку при установке Ubuntu, не создав для нее primary раздела.
А windows возможно не загружается из-за того, что не находит ntldr, хотя он есть на диске С.

Есть ли еще какие-нибудь версии ?

Пользователь решил продолжить мысль 27 Май 2010, 13:25:59:
Апдейт.
Пишу уже с винды, flash1, огромное спасибо  :)

Изменил boot.ini на и все заработало. Действительно, проблема была в этих signature(a33b6c03)
Цитировать
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional RU" /execute /fastdetect
« Последнее редактирование: 27 Май 2010, 15:26:36 от Maagog »

Оффлайн flash1

  • Участник
  • *
  • Сообщений: 131
  • city cat
    • Просмотр профиля
Похоже что слетел какой то атрибут с загрузочного раздела Windows, попробуйте просмотреть атрибуты этого раздела например в Acronis Disk Director, PartedMagic и т.д., если все ок (статус: загрузочный, активный, видимый и т.д.) то как уже и сказали выше проверьте этот раздел с помощью команды chkdisk, если и это не поможет то попробуйте рекомендуемую в таких ситуациях операцию, но сразу говорю что потом придется восстанавливать Grub !, и если процедура пройдет не удачно (Windows все равно не захочет загружаться) до восстановления Grub Ubuntu тоже не будет загружаться !, поэтому решать Вам самим делать этот пункт или нет, сама процедура состоит в том что с загрузочного диска с Windows нужно загрузиться и в меню выбора установка-восстановление выбрать не установку а "R" восстановление в консоли (тоже самое можно сделать и для chkdsk), появится консоль (cmd), войти на раздел с установленной Windows и (может попросить админский пароль, ввести его) выполнить команду fixboot (для отображения всех доступных команд ввести команду help), согласиться с изменениями "Y" и по завершении процедуры перезагрузить ПК.

P.S. кстати перед всеми этими экспериментами можно создать бэкап этих разделов на другой HDD, например на USB HDD (для того что бы в случае неудачи восстановить хотя бы нынешнее состояние HDD, кстати и перед установкой Ubuntu можно было забэкапить Windows), для этого есть соответствующие утилиты и загрузочные диски такие как Acronis True Image, PartedMagic, Clonezilla и т.д.

Пользователь решил продолжить мысль 27 Май 2010, 15:35:42:
это хорошо, значит мой "краткий" мануальчик уже не нужен  ;D
« Последнее редактирование: 27 Май 2010, 15:35:42 от flash1 »
Debian 6 Squeeze (work-home), Windows 2003 R2 SP2 Enterprise (work-home).

 

Страница сгенерирована за 0.055 секунд. Запросов: 22.