Форум русскоязычного сообщества Ubuntu


Автор Тема: Ubuntu 10.04 - не работает vdpau после рестарта gdm  (Прочитано 2305 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн roast_swan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Добрый день.
Я обновился с Ubuntu 9.10 до 10.04.
После обновления mplayer перестал проигрывать DVD.
Я поставил недостающие кодеки, как описано здесь: http://www.ubuntugeek.com/install-mplayer-and-multimedia-codecs-libdvdcss2w32codecsw64codecs-in-ubuntu-10-04-lucid-lynx.html
DVD заработало.

Также при обновлении слетел пакет libvdpau1, я его восстановил из стандартного репозитория. (Здесь была похожая проблема: http://www.linux.org.ru/forum/desktop/4837500?lastmod=1272704550978)

После этого vdpau заработало, но только сразу после перезагрузки.
После рестарта gdm (выбором команды "Завершить сеанс", либо sudo service gdm stop/start, либо Ctrl+Alt+Backspace) выдает ошибку

mplayer -nolirc -vc ffh264vdpau -vo vdpau Tchaikovsky.The.Nutcracker.2007.720p.BluRay.DTS.LPCM.HDCLUB.mkv
MPlayer SVN-r1.0~rc3+svn20090426-4.4.3 (C) 2000-2009 MPlayer Team

Playing Tchaikovsky.The.Nutcracker.2007.720p.BluRay.DTS.LPCM.HDCLUB.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_DTS) "DTS 5.1 @ 1536 kbps", -aid 0, -alang eng
[mkv] Track ID 3: audio (A_PCM/INT/LIT) "PCM 2.0 @ 2304 kbps", -aid 1, -alang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [avc1] 1280x720 24bpp 29.970 fps 0.0 kbps ( 0.0 kbyte/s)
[vdpau] Error when calling vdp_device_create_x11: 1
Error opening/initializing the selected video_out (-vo) device.
==========================================================================
Opening audio decoder: [libdca] DTS decoding with libdca
Stream with high frequencies VQ coding
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [dts] afm: libdca (DTS-libdca)
==========================================================================
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 1.6 (01.5) of 5299.6 ( 1:28:19.6) 8.9%


После перезагрузки все опять работает.

Я обновил libvdpau1 из репозитория https://launchpad.net/~nvidia-vdpau/+archive/ppa, но это не помогло, та же ошибка.

Вот здесь http://www.linux.org.ru/jump-message.jsp?msgid=4764700&cid=4771431 описана та же ошибка, но решения пока нет.

Карта nvidia 9600M GT
Ноут http://www.acerdirect.co.uk/Acer_Aspire_6935G-944G32Bn_Gemstone_Blue_Laptop_LX.ATQ0X.038/version.asp#top
Драйвер поставился по умолчанию, 195.36.15-0ubuntu3, из стандартного репозитория.
В 9.10 был 185, все работало.

Поделитесь советом, плиз.

Заметил такую особенность, не знаю, связано ли это с сабжем:
Сразу после загрузки gdm стартует с седьмой консоли, т.е. при выходе в виртуальную консоль по Ctrl+Alt+F2 обратно попадаем по Ctrl+Alt+F7.
После рестарта gdm находится в восьмой консоли, Ctrl+Alt+F8.
Если запустить дополнительно guest session, она стартует с девятой консоли. Дальше я не проверял.
Так и должно быть?
В karmic вроде всегда с седьмой стартовало.

При загрузке тоже странные вещи происходят.
karmic я устанавливал с Alternate CD на шифрованный LVM. Грузился в текстовом режиме, т.е. без "quiet splash". Загрузка доходила до запроса пароля, при вводе пароль не отображался звездочками, после ввода пароля загрузка продолжалась нормально.
После обновления до lucid строки загрузки отображаются как-то криво, лесенкой, при вводе пароля он отображается звездочками и при вводе каждого символа заново выводится строка приглашения. Это мне не понравилось, и я снова поставил "quiet splash".

Оффлайн aleksubuntu

  • Активист
  • *
  • Сообщений: 254
    • Просмотр профиля
sudo aptitude install smplayer libvdpau1 libvdpau-doc
SMPlayer: настройки устройство вывода vdpau
перезапустить SMPlayer
ASUS A8N-VM CSM, amd64 x2 4400, 2Gb, WD320Gb, GTX260GS, window7 x64 & kubuntu-12.10-desktop-amd64, s-1401, s2-3200ci, aspire 5745dg

Оффлайн roast_swan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Все эти пакеты у меня установлены.
В SMPlayer та же ошибка в логе.

Оффлайн Демагог

  • Активист
  • *
  • Сообщений: 513
    • Просмотр профиля
Я обновился с Ubuntu 9.10 до 10.04.

видимо, в этом проблема.

Оффлайн roast_swan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Я обновился с Ubuntu 9.10 до 10.04.

видимо, в этом проблема.

Спасибо, кэп.

Оффлайн nikulyan

  • Активист
  • *
  • Сообщений: 858
  • Чем хуже дела у Мелкософта, тем лучше у Linux'а
    • Просмотр профиля
А что помогло, не напишешь?

Оффлайн roast_swan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Ubuntu 10.04 - не работает vdpau после рестарта gdm
« Ответ #6 : 19 Август 2010, 01:56:08 »
А что помогло, не напишешь?
Пока ничего, все по-старому.
Я уже привык:)

Оффлайн roast_swan

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Ubuntu 10.04 - не работает vdpau после рестарта gdm
« Ответ #7 : 06 Январь 2012, 14:52:07 »
Проблема решилась сама собой после очередного обновления системы.
Всем спасибо  :)

 

Страница сгенерирована за 0.063 секунд. Запросов: 25.