Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Неразрешенные зависимости 16.04 LTS  (Прочитано 1971 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sm4ll_3gg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Неразрешенные зависимости 16.04 LTS
« : 08 Октябрь 2016, 15:24:15 »
Не так давно я установил Open Office. Вчера нужно было поработать с текстовым редактором и я решил, что OO для linux очень не удобен, для меня. Решил поставить обратно Libreoffice. Удалил OO (sudo apt-get remove openoffice), всё прошло нормально. Но при установке LO (sudo apt-get install libreoffice) возникла какая-то ошибка(вылезла уведомлением), не помню точно что там уже было написано, не придал этому значения.
Когда установка закончилась не нашел LO в поиске. Попробовал переустановить. Ничего не вышло, в терминале во время установки вылезло это
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libreoffice-common_1%3a5.1.4-0ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Пробовал несколько раз, эффекта никакого. Залез в менеджер приложений и оказалось, что там LO помечен как установленный. Попробовал удалить его оттуда, что-то вроде происходит, но он так же остаётся установленным.
Так как мне срочно нужно было делать работу и времени разбираться не было, решил поставить OO обратно(и это, скорее, мне кажется, было очень зря). Скачал с сайта пакет и установил их. Всё прошло нормально, доделал работу. Сегодня таки решил разобраться что пошло не так. Попробовал сделать как советует ubuntu (sudo apt-get -f install), вылазит тоже, что и при установке уже любой программы (см. выше). Попробовал сначала удалить OO, вылезает сообщение о неудовлетворённых зависимостях:
Пакеты, имеющие неудовлетворённые зависимости:
 libreoffice-core : Зависит: libreoffice-common (> 1:5.1.4) но он не будет установлен
 libreoffice-java-common : Зависит: libreoffice-common (= 1:5.1.4-0ubuntu1) но он не будет установлен
 libreoffice-style-elementary : Зависит: libreoffice-common (= 1:5.1.4-0ubuntu1) но он не будет установлен
 libreoffice-style-galaxy : Зависит: libreoffice-common (= 1:5.1.4-0ubuntu1) но он не будет установлен
 openoffice-brand-base : Зависит: openoffice но он не будет установлен
 openoffice-brand-calc : Зависит: openoffice но он не будет установлен
 openoffice-brand-draw : Зависит: openoffice но он не будет установлен
 openoffice-brand-impress : Зависит: openoffice но он не будет установлен
 openoffice-brand-math : Зависит: openoffice но он не будет установлен
 openoffice-brand-ru : Зависит: openoffice но он не будет установлен
 openoffice-brand-writer : Зависит: openoffice но он не будет установлен
Погуглил по этому поводу, но ничего не помогает. Всё, что ни сделаешь ссылается либо на зависимости, либо на ошибку в обработке того пакета (см. выше).
В частности, пытался решить проблему по этой статье - http://help.ubuntu.ru/wiki/%D1%80%D0%B5%D1%88%D0%B5%D0%BD%D0%B8%D0%B5_%D0%BF%D1%80%D0%BE%D0%B1%D0%BB%D0%B5%D0%BC_%D1%81_%D0%B7%D0%B0%D0%B2%D0%B8%D1%81%D0%B8%D0%BC%D0%BE%D1%81%D1%82%D1%8F%D0%BC%D0%B8
Толку 0

Оффлайн luu

  • Активист
  • *
  • Сообщений: 674
  • шта?
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #1 : 08 Октябрь 2016, 15:31:44 »
Вот вроде ваш случай.

Оффлайн superguest

  • Любитель
  • *
  • Сообщений: 94
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #2 : 08 Октябрь 2016, 15:52:04 »
sudo dpkg --configure -aделали?
потом удалить и установить заново

Оффлайн sm4ll_3gg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #3 : 08 Октябрь 2016, 16:31:58 »
Вот вроде ваш случай.
Не работает, выдает туже ошибку с .deb пакетом

Пользователь добавил сообщение 08 Октябрь 2016, 16:35:51:
sudo dpkg --configure -aделали?
потом удалить и установить заново
При выполнении команды вылезает куча ошибок типа
dpkg: ошибка при обработке пакета libreoffice-report-builder-bin (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет libreoffice-base-core:
 libreoffice-base-core зависит от libreoffice-core (= 1:5.1.4-0ubuntu1), однако:
  Пакет libreoffice-core пока не настроен.
А в конце
При обработке следующих пакетов произошли ошибки:
 libreoffice-style-galaxy
 libreoffice-java-common
 libreoffice
 libreoffice-sdbc-hsqldb
 libreoffice-core
 libreoffice-calc
 libreoffice-style-elementary
 python3-uno
 libreoffice-base-drivers
 libreoffice-gnome
 libreoffice-pdfimport
 libreoffice-gtk
 libreoffice-draw
 libreoffice-avmedia-backend-gstreamer
 libreoffice-writer
 libreoffice-impress
 libreoffice-sdbc-firebird
 libreoffice-base
 libreoffice-math
 libreoffice-report-builder-bin
 libreoffice-base-core
« Последнее редактирование: 08 Октябрь 2016, 16:35:51 от sm4ll_3gg »

Valan

  • Гость
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #4 : 08 Октябрь 2016, 18:23:13 »
Удалить через dpkg -r , dpkg --purge попробуй.

Оффлайн sm4ll_3gg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #5 : 08 Октябрь 2016, 19:41:02 »
Удалить через dpkg -r , dpkg --purge попробуй.
Что именно удалить?

Valan

  • Гость
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #6 : 09 Октябрь 2016, 02:45:18 »
Что именно удалить?
Пакеты которые проблемы вызывают. Бывает такое что apt не может справиться.
Вот тебе как пример http://forums.debian.net/viewtopic.php?p=569608
« Последнее редактирование: 09 Октябрь 2016, 02:50:45 от Valan »

Оффлайн sm4ll_3gg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #7 : 09 Октябрь 2016, 19:22:45 »
Что именно удалить?
Пакеты которые проблемы вызывают. Бывает такое что apt не может справиться.
Вот тебе как пример http://forums.debian.net/viewtopic.php?p=569608
Спасибо, помогло.
Смог удалить openoffice, но установить libre всё равно не получается. Во время установки вылезает та же ошибка
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libreoffice-common_1%3a5.1.4-0ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Пробовал удалить этот пакет и выполнить sudo apt-get -f install, но не помогает. Ошибка опять вылезает

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #8 : 09 Октябрь 2016, 19:33:29 »
Пробовал удалить этот пакет
Как, пакетным менеджером? Нужно удалить сам файл, "руками".

Оффлайн sm4ll_3gg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #9 : 09 Октябрь 2016, 20:28:45 »
Пробовал удалить этот пакет
Как, пакетным менеджером? Нужно удалить сам файл, "руками".
sudo rm /var/cache/apt/archives/libreoffice-common_1%3a5.1.4-0ubuntu1_all.deb

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #10 : 09 Октябрь 2016, 20:41:10 »
Ошибка опять вылезает
Ошибка та же?

Оффлайн sm4ll_3gg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #11 : 09 Октябрь 2016, 20:49:35 »
Ошибка опять вылезает
Ошибка та же?
Да, та же самая с этим же пакетом

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #12 : 09 Октябрь 2016, 21:01:17 »
Код: Bash
  1. sudo apt-get clean
  2. sudo apt-get install -f
И показывай что отвечает терминал, под спойлер...

Оффлайн sm4ll_3gg

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #13 : 09 Октябрь 2016, 21:17:00 »
Код: Bash
  1. sudo apt-get clean
  2. sudo apt-get install -f
И показывай что отвечает терминал, под спойлер...
(Нажмите, чтобы показать/скрыть)

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
Re: Неразрешенные зависимости 16.04 LTS
« Ответ #14 : 09 Октябрь 2016, 21:27:10 »
Может в репозитории пакет с ошибкой. Попробуй сменить зеркало и проделать тоже самое снова.

 

Страница сгенерирована за 0.073 секунд. Запросов: 25.