Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Пакеты ubuntu-desktop и unity.  (Прочитано 1407 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SAL1Mbl4

  • Автор темы
  • Участник
  • *
  • Сообщений: 109
  • Юзверь, но исправляюсь.
    • Просмотр профиля
Пакеты ubuntu-desktop и unity.
« : 09 Январь 2017, 16:14:58 »
Всем снова привет. Не успел я порадоваться успешной установке скайпа, как у меня слетел дефолтный убунтовский интерфейс... Благо, нашел гномовский, сейчас с него и сижу. Но хочется вернуть старый. Покопавшивсь в инете, я не нашел толковых решений. Зато понял, что пакеты ubuntu-desktop и unity снесены. Устанавливаться они не хотят ни через синаптик:Не удалось выполнить изменения!
Сначала необходимо исправить ошибки в пакетах.
Ни через терминал:
danil@DanilPC:~$ sudo apt-get install ubuntu-desktop
Password:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 ubuntu-desktop : Зависит: unity но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

danil@DanilPC:~$ sudo apt-get install unity
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 unity : Зависит: compiz но он не будет установлен
         Зависит: compiz-plugins-default но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

danil@DanilPC:~$ sudo apt-get install compiz
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 compiz : Зависит: compiz-plugins-default (>= 1:0.9.11.3+14.04.20150313-0ubuntu1) но он не будет установлен
          Зависит: compiz-gnome но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

danil@DanilPC:~$ sudo apt-get install compiz-gnome
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 compiz-gnome : Зависит: compiz-plugins-default (= 1:0.9.11.3+14.04.20150313-0ubuntu1) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

danil@DanilPC:~$ sudo apt-get install compiz-plugins-default
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 compiz-plugins-default : Зависит: libdecoration0 (= 1:0.9.11.3+14.04.20150313-0ubuntu1) но 1:0.9.11.3+14.04.20160425-0ubuntu1 будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

danil@DanilPC:~$ sudo apt-get install libdecoration0
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия libdecoration0.
Следующие пакеты устанавливались автоматически и больше не требуются:
  libatk-bridge2.0-dev libatk1.0-dev libcairo-script-interpreter2
  libcairo2-dev libdecoration0-dev libexpat1-dev libfontconfig1-dev
  libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev libglibmm-2.4-dev
  libgtk-3-dev libharfbuzz-dev libharfbuzz-gobject0 libpango1.0-dev
  libpcre3-dev libpcrecpp0 libpng12-dev libsigc++-2.0-dev
  libstartup-notification0-dev libwayland-dev libxcb-shm0-dev
  libxcomposite-dev libxcursor-dev libxft-dev libxi-dev libxinerama-dev
  libxkbcommon-dev libxrandr-dev libxrender-dev libxslt1-dev
  linux-tools-3.13.0-34 linux-tools-3.13.0-34-generic re2c wine-gecko2.24
  wine-gecko2.24:i386 wine-mono4.5.2 x11proto-composite-dev
Для их удаления используйте «apt-get autoremove».
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
danil@DanilPC:~$
Также пробовал устанавливать все вышеперечисленные пакеты через синаптик. Выдает все ту же ошибку пакетов.
Такие дела. Как быть?

Пользователь добавил сообщение 09 Январь 2017, 16:15:40:
Ах, да. Интерфейс слетел после команды
sudo apt-get autoremove

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6780
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #1 : 10 Январь 2017, 00:38:06 »
А какая версия Ubuntu? Сдаётся мне, что либо старая не поддерживаемая, либо новая тестовая.
Ошибку с пакетами можно попробовать устранить так:
sudo apt install -f

Оффлайн ol_denkin

  • Активист
  • *
  • Сообщений: 477
  • не то, что вы думаете
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #2 : 10 Январь 2017, 01:16:13 »
SAL1Mbl4, сделай то что советует maks05 и постарайся вспомнить и рассказать, что ты делал (удалял) перед тем как сделать autoremove?

сторонние репозитории какие подключены?

Оффлайн SAL1Mbl4

  • Автор темы
  • Участник
  • *
  • Сообщений: 109
  • Юзверь, но исправляюсь.
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #3 : 10 Январь 2017, 01:19:41 »
maks05, ubuntu 14.04.5 lts. Команда не помогает.

Пользователь добавил сообщение 10 Январь 2017, 01:20:16:
ol_denkin, сейчас сказать не могу, попозже.
« Последнее редактирование: 10 Январь 2017, 16:15:12 от SAL1Mbl4 »

Оффлайн ol_denkin

  • Активист
  • *
  • Сообщений: 477
  • не то, что вы думаете
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #4 : 10 Январь 2017, 01:24:39 »
maks05, ubuntu 14.0.5 lts. Команда не помогает.
а что пишет то?

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6780
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #5 : 10 Январь 2017, 07:47:15 »
SAL1Mbl4, странно: 12.04.5 должна поддерживаться. И вообще, autoremove интерфейс не стирает.

Оффлайн SAL1Mbl4

  • Автор темы
  • Участник
  • *
  • Сообщений: 109
  • Юзверь, но исправляюсь.
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #6 : 10 Январь 2017, 09:16:35 »
ol_denkin, maks05,
danil@DanilPC:~$ sudo apt install -f
Password:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  libatk-bridge2.0-dev libatk1.0-dev libcairo-script-interpreter2
  libcairo2-dev libdecoration0-dev libexpat1-dev libfontconfig1-dev
  libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev libglibmm-2.4-dev
  libgtk-3-dev libharfbuzz-dev libharfbuzz-gobject0 libpango1.0-dev
  libpcre3-dev libpcrecpp0 libpng12-dev libsigc++-2.0-dev
  libstartup-notification0-dev libwayland-dev libxcb-shm0-dev
  libxcomposite-dev libxcursor-dev libxft-dev libxi-dev libxinerama-dev
  libxkbcommon-dev libxrandr-dev libxrender-dev libxslt1-dev
  linux-tools-3.13.0-34 linux-tools-3.13.0-34-generic re2c wine-gecko2.24
  wine-gecko2.24:i386 wine-mono4.5.2 x11proto-composite-dev
Для их удаления используйте «apt-get autoremove».
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

Пользователь добавил сообщение 10 Январь 2017, 09:17:42:
ol_denkin, вот эти вроде удалились.
danil@DanilPC:~$ sudo apt-get install -f
Password:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  fonts-sil-gentium fonts-sil-gentium-basic libappindicator1 libhdb9-heimdal
  libindicator7 libkdc2-heimdal libreoffice-report-builder-bin
  linux-headers-3.13.0-34 linux-headers-3.13.0-34-generic
  linux-image-3.13.0-34-generic linux-image-extra-3.13.0-34-generic
  localechooser-data
Для их удаления используйте «apt-get autoremove».
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 25 пакетов не обновлено.
danil@DanilPC:~$

Пользователь добавил сообщение 10 Январь 2017, 09:24:45:
ol_denkin,
« Последнее редактирование: 10 Январь 2017, 09:24:46 от SAL1Mbl4 »

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6780
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #7 : 10 Январь 2017, 10:31:18 »
SAL1Mbl4, винегрет у вас в репозиториях. Вижу Mint и сборку от ua.linux, в которых неизвестно что и как. А обычная, официальная Ubuntu с Unity на этом компе хоть была?
Команда install -f помогла?

P.S. В 16.04 - apt и apt-get, а в 14.04 только apt-get.

P.P.S. Ставьте стандартную Ubuntu 16.04 и будет вам счастье. 
« Последнее редактирование: 10 Январь 2017, 10:35:22 от maks05 »

Оффлайн SAL1Mbl4

  • Автор темы
  • Участник
  • *
  • Сообщений: 109
  • Юзверь, но исправляюсь.
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #8 : 10 Январь 2017, 12:08:16 »
maks05, в том то и дело, что была. Но прописав авторемув удалилась.
инсталл ф не помогла также.
А можно ли просто обновить версию без переустановки?

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6780
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #9 : 10 Январь 2017, 13:54:05 »
SAL1Mbl4, тут важно, была как основная или как дополнительная. Если как дополнительная к mint, то могла и удалиться (хотя, тоже странно).
Обновить версию можно, но в вашем случае, когда у вас и так проблемы, лучше всё снести и поставить с нуля.

Оффлайн SAL1Mbl4

  • Автор темы
  • Участник
  • *
  • Сообщений: 109
  • Юзверь, но исправляюсь.
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #10 : 10 Январь 2017, 15:07:56 »
maks05, у меня по дефолту стояла панель гномовская. В систему была предустановлена юнити, гном и еще 2 какие-то, я их не юзаю. А переустанавливать ой как не хочется(

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6780
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #11 : 10 Январь 2017, 15:58:42 »
SAL1Mbl4, не хочется, но надо.  ;)
Если серьёзно, то у вас была нестандартная версия. Признавайтесь, что ставили. Хотя, это уже без разницы - вы и так уже проблем огребли.
Теперь у вас два варианта:
1) Работать на том, что есть, если оно, конечно, работает.
2) Если хотите нормально работающую Unity, то ставьте стандартную Ubuntu с оф. сайта или с нашего сайта (ещё можно с зеркал Яндекса).

Оффлайн SAL1Mbl4

  • Автор темы
  • Участник
  • *
  • Сообщений: 109
  • Юзверь, но исправляюсь.
    • Просмотр профиля
Re: Пакеты ubuntu-desktop и unity.
« Ответ #12 : 10 Январь 2017, 16:14:02 »
ЗАРАБОТАЛО!  :D
Решение нашел тут:
https://forum.ubuntu.ru/index.php?topic=246248.0
Причем когда повторял все эти шаги раньше, не помогало. В общем, сначала я скачал с оф. сайта все пакеты, нужные для ubuntu-desktop и unity(через консоль зависимости показывает) и установил через
sudo dpkg -i *имя_пакета*Затем установил compizconfig settings manager и включил плагин unity со всеми зависимыми плагинами.
Ну и повторил все шаги из темы выше. Всем спасибо, все свободны  ;D
« Последнее редактирование: 11 Январь 2017, 12:22:16 от SAL1Mbl4 »

 

Страница сгенерирована за 0.239 секунд. Запросов: 24.