Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Слетает обратно на экран входа после попытки войти систему.  (Прочитано 3143 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lombtiol

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Ubuntu 19.04
После ввода пароля черный экран, фиолетовая вспышка, опять окно входа.
Перед всем этим я ничего не устанавливал и не обновлял.
Такую же проблему можно найти в интернетеПервое что сделал: rm .Xauthority .ICEauthority
Но у меня файла .Xauthority вообще не существует.

Потом намудрил чего-то с драйверами. Я не профессионал и не претендую на это.
Это видимо  проблема с драйвером видеокарты.
у меня GeForse GT 750M и встроенный intel.
<ссылки на изображения битые, и потому удалены модератором>
Что делать не знаю.
Как откатить ядро и драйвер видеокарты?
Или проблема вообще не в этом?
(Нажмите, чтобы показать/скрыть)

ТС не появлялся на Форуме более трех месяцев по состоянию на 18/03/2020 (последняя явка: 03/11/2019). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 18 Март 2020, 11:30:47 от zg_nico »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
Что делать не знаю.
Семь бед? Nomodeset (конкретно смотрите раздел "Типовые проблемы", п. 3 и этот алгоритм загрузки с параметром nomodeset)!
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн ReNzRv

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Цитировать
Потом намудрил чего-то с драйверами
Вспоминай и пиши или переустанавливай систему

Оффлайн ol_denkin

  • Активист
  • *
  • Сообщений: 498
  • не то, что вы думаете
    • Просмотр профиля
1. Зайти в терминал (Ctrl+Alt+F1)
2. Ввести логин (тот который вводил при установке)
3. Ввести пароль
4. Удалить файл .Xauthority командой
rm .Xauthorityвводить команду тщательно, соблюдая регистр в имени файла
5. Выйти из терминальной сессии, введя команду
exit6. Вернуться в графическое окно входа (Ctrl+Alt+F7)
7. Попробовать залогиниться

Еще вариант - переполнение раздела, нет свободного места.
Тут уж стоит зайти в установочной флешки (диска) и пробовать аккуратно чистить, начиная с каталога /home/ИМЯ_ПОЛЬЗОВАТЕЛЯ/.local/share/Trash

Оффлайн lombtiol

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Семь бед? Nomodeset (конкретно смотрите раздел "Типовые проблемы", п. 3 и этот алгоритм загрузки с параметром nomodeset)!
Сделал все как в инструкции.
Система вроде загружается, потом 5 секунд черный экран с _ наверху и выдает: [   87.323797]hdaudio hdaudioC03D:Unable to bind the codec
Вроде можно ка то сделать загрузку с флешкой или я что то путаю?
Очень не хотелось бы переустанавливать систему, всё заново потом переустанавливать и настраивать.
Может все таки связано с тем что у меня .Xauthority не существует. (ls -la и его там нет)
Вспоминай и пиши
$ history: [url=http://lostpic.net/image/qn6h]http://lostpic.net/image/qn6h[/url]
(Нажмите, чтобы показать/скрыть)
соблюдая регистр в имени файла
:|
переполнение раздела, нет свободного места.
600Gb думаю хватит
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 30 Октябрь 2019, 09:04:33 от zg_nico »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4478
    • Просмотр профиля
Цитировать
600Gb думаю хватит
600гб чего, где.
Он тоже думал, что хватит.

Оффлайн lombtiol

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Он тоже думал, что хватит.
$df -h: [url=http://lostpic.net/image/qn1j]http://lostpic.net/image/qn1j[/url]
(Нажмите, чтобы показать/скрыть)
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 30 Октябрь 2019, 09:05:52 от zg_nico »

Оффлайн Sly_tom_cat

  • Don't worry, be happy!
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 12090
  • Xubuntu 20.04
    • Просмотр профиля
    • Github
Если удаление .Xauthority не помогло попробуй еще почистить каталог /home/$USER/.cache/sessions/
Индикатор для Yandex-Disk: https://forum.ubuntu.ru/index.php?topic=241992
UEFI-Boot - грузимся без загрузчика: https://help.ubuntu.ru/wiki/uefiboot

Оффлайн lombtiol

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Если удаление .Xauthority не помогло
У меня нет .Xauthority, совсем нет. И не было с самого начала, как только возникла эта проблема я первое что сделал это пошел его удалять, а его не оказалось.

попробуй еще почистить каталог /home/$USER/.cache/sessions/
В директории .cache/, sessions отсутствует.

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
Система вроде загружается, потом 5 секунд черный экран
Так. Начнем плясать от печки.
Перед всем этим я ничего не устанавливал и не обновлял.
Правильно ли я трактую Ваши слова: сразу после установки система успешно загружалась и работала. Вы установили проприетарный драйвер от производителя видеокарты, и система после установки драйвера загружалась и работала. Все верно?
Для отсечки по признаку в видео дело или не в видео предлагалось загрузиться с параметром ядра nomodeset. Вы эту загрузку выполнили? Что означает
Система вроде загружается
Загружается - значит Вы увидели графический интерфейс, Вы манипулируете курсором, Вы видите свой рабочий стол. Все прочее = НЕ ЗАГРУЖАЕТСЯ. Никаких "вроде". Поясните что именно происходит. Если видите черный экран, на нем висит надпись [   87.323797]hdaudio hdaudioC03D:Unable to bind the codecто это, по сути, "не загружается", хоть я и смутно себе представляю ситуацию, когда данный варнинг был бы связан с невозможностью войти в систему (в общем и целом войти скорее можно будет, но отвалится звук по логике вещей). Призываю Вас описывать ситуацию подробнее, ибо сейчас мы гадаем на кофейной гуще. Все что нам от Вас известно - это то что "ононеработает". Чем больше подробностей - тем выше вероятность того, что кто-нибудь смекнет что именно у Вас происходит, и предложит решение, - призываю Вас понять это.
Вспомните: что последнее делали до начала этих проблем? Обновлялась ли система? Было ли некорректное завершение работы? Возможно, Вами выполнялась установка каких-либо пакетов или редактирование каких-либо файлов? К примеру, с чего Вы вообще начали возиться с драйвером?
Потом намудрил чего-то с драйверами.
Не просто же так пришла в голову идея - значит что-то Вас на эту мысль натолкнуло. Поясните.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн lombtiol

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Правильно ли я трактую Ваши слова: сразу после установки система успешно загружалась и работала. Вы установили проприетарный драйвер от производителя видеокарты, и система после установки драйвера загружалась и работала. Все верно?
Нет. Я начал все действия с драйверами после возникновения этой проблемы, тем самым пытаясь ее устранить. Выше приведен срез истории  команд, выполненных после возникновения этой ошибки. До этой ошибки я вообще ничего не делал системой, разве что устанавливал и использовал unetbootin.

Загружается - значит Вы увидели графический интерфейс, Вы манипулируете курсором, Вы видите свой рабочий стол. Все прочее = НЕ ЗАГРУЖАЕТСЯ.
Значит не загружается. Делаю все по инструкции: нажимаю F10 -> идет загрузка с показом логов загрузки -> черный экран 5 секунд -> показывается [   87.323797]hdaudio hdaudioC03D:Unable to bind the codec и больше ничего не происходит.

По 2,3 ссылке моего первого поста, говорится о драйверах как причине проблемы.

Может где то можно посмотреть лог обновлений может что и обновилась, а я не помню, но это вряд ли.
Что то надо попробовать, я бы попробовал откатить ядро и драйвер Nvidia до точно совместимых, но не знаю как.


Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
lombtiol, загрузка с предыдущим ядром делается из grub2. Выбирайте там пункт "Дополнительные параметры для Ubuntu" и в этом меню выбирайте желаемую версию драйвера.
Логи посмотреть можно, но было бы неплохо понять что именно смотреть. А то Вы фотографии загружать устанете, а мы - рассматривать, ИМХО.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн lombtiol

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Еще раз переустанавливал драйвера nvidia теперь вообще не грузится. При включении показывается лог загрузки и останавливается на:
(Нажмите, чтобы показать/скрыть)
и больше ничего не происходит. Если нажать на кнопку вкл/выкл то показывается:
(Нажмите, чтобы показать/скрыть)
и компьютер выключается.
Буду Устанавливать новую, но нужно как то вытащить все файлы из из домашнего каталога. И файлы закладок из Chrome и Opera. вообще не представляю как это сделать.
Не могу найти ничего про то можно или нет как то загрузится на этой ос используя загрузочную флешку или восстановления системы, ничего не могу понять по этому поводу.
Можно как то можно поставить новую ubuntu  рядом с этой что бы начать уже работать и постепенно пытаться вытащить файлы из старой ос.
« Последнее редактирование: 30 Октябрь 2019, 09:06:35 от zg_nico »

cgpk00

  • Гость
У меня нет .Xauthority, совсем нет. И не было с самого начала, как только возникла эта проблема я первое что сделал это пошел его удалять, а его не оказалось.
Оно сейчас здесь /run/user/1000/gdm

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
Еще раз переустанавливал драйвера nvidia теперь вообще не грузится
в самых печальных вариациях установки драйвера, когда "ничего не грузится" - загружаемся в текстовом режиме с параметром ядра single, удаляем драйвера (что вызовет автоматом переход обратно на nouveau), далее перезагружаемся:
При загрузке с параметром ядра single пароль НЕ НУЖЕН. Вы автоматически, по-умолчанию - рут. Просто не в графическом режиме.
Значит так: грузимся с параметром single. Объясняю пошагово. Исходное состояние: ноутбук/ПК выключен. Нажимаем кнопку включения. Дожидаемся появления экрана GRUB2 (это там, где черный/фиолетовый экран и первая строчка - Ubuntu; если такое вообще не появляется [бывает, когда Ubuntu - единственная система] - при загрузке следует либо держать зажатым Shift, либо отчаянно долбить по Shift, пока такое меню не появится), не давая загрузчику начать загрузку (извините за тавтологию) нажмите клавишу 'e'. Появится текстовый редактор. Глазами находим слова " quiet splash ". Стрелочками на клавиатуре наводим курсор (он прямоугольный и мерцает) в эту область, вписываем туда с клавиатуры "single", а эти quiet и splash стираем с помощью backspace или delete (по вкусу). Было:... quiet splash ...После манипуляций стало:... single ...далее жмем F10. Пойдет загрузка, побегут строчки в терминале. Во время загрузки будет пауза в терминале, и будет написаноPress Enter for maintenance
(или нажмите Control-D для продолжения)
Жмем здесь Enter. Загрузка на этом остановится, т.к. Вы уже загрузились и Вы уже - рут. Поздравляю, кстати. Ниже видим командную строку видаroot@<имя_машины>:~#Вводим туда:grep -H nouveau /*/modprobe.d/*Вывод показываем на форуме любым удобным способом (сфотографировать можете и выложить на любой хостинг - я поправлю при необходимости). Далее там же вводим такую связку:apt purge nvidia* && apt autoremove && rebootМашина уходит в перезагрузку.
!!! Если вывод команды (строчка внутри цитаты выделена жирным шрифтом) не пустой - сперва [до всех дальнейших манипуляций] покажите фото экрана с этим выводом (драйвер nouveau попал в blacklist и надо его оттуда достать)
После загрузки пробуйте стартовать как есть. Посмотрите к чему приведет. Если черный экран или еще какие проблемы - первым белом пробуем грузить с nomodeset.
Если не помогает - покажите на чем замирает загрузка на сей раз. Если загружается но по-прежнему не пускает в систему - то попробуйте рекомендацию cgpk00 по расположению файла, который не могли найти ранее. andytux, спасибо!

« Последнее редактирование: 26 Октябрь 2019, 08:32:58 от zg_nico »
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

 

Страница сгенерирована за 0.09 секунд. Запросов: 23.