Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: При компиляции cmake требует Boost  (Прочитано 1702 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн APACHE

  • Автор темы
  • Участник
  • *
  • Сообщений: 169
  • Windows 7
    • Просмотр профиля
При компиляции cmake требует Boost
« : 08 Февраль 2009, 01:34:57 »
andrey@andrey-desktop:~/Астрономия/Астрософт/stellarium-0.10.1/builds/unix$ cmake ../..
-- Boost version required: . Found: ..
CMake Error at /usr/share/cmake-2.6/Modules/FindBoost.cmake:553 (MESSAGE):
  Couldn't find the Boost libraries and/or include directory, or the version
  found is too old.  Please install the Boost libraries AND development
  packages.  You can set BOOST_ROOT, BOOST_INCLUDEDIR and BOOST_LIBRARYDIR to
  help find Boost.
Call Stack (most recent call first):
  CMakeLists.txt:108 (FIND_PACKAGE)


-- Configuring done

Не пойму - что за Boost? В инете смотрел так и не врубился... До этого требовал qt4 - поставил.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: При компиляции cmake требует Boost
« Ответ #1 : 08 Февраль 2009, 01:38:03 »
Поиск по слову boost в менеджере пакетов спасёт. По крайней мере очень на это надеюсь.

Оффлайн APACHE

  • Автор темы
  • Участник
  • *
  • Сообщений: 169
  • Windows 7
    • Просмотр профиля
Re: При компиляции cmake требует Boost
« Ответ #2 : 08 Февраль 2009, 01:39:44 »
В Synaptic смотрел нету...

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: При компиляции cmake требует Boost
« Ответ #3 : 08 Февраль 2009, 01:42:09 »
Плохо искал. Должно быть  :coolsmiley:

Оффлайн Yurror

  • Старожил
  • *
  • Сообщений: 1966
    • Просмотр профиля
Re: При компиляции cmake требует Boost
« Ответ #4 : 08 Февраль 2009, 16:32:23 »
Там буст собран по полной программе. Вытянет какую-то просто нереальную кучу байт.
Нет мне не жалко интернета. Меня бесит зависимость от python'а некоторых библиотек.
С какого перепугу они С++ библиотеку собрали с питоном. Последний релиз Ubuntu меня все больше разочаровывает  :-\

Пойду в команду AlexOS64 project:D

P.S. boost вполне себе нормально без извратов собирается руками.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: При компиляции cmake требует Boost
« Ответ #5 : 09 Февраль 2009, 01:36:46 »
Python, потому что http://www.boost.org/doc/libs/1_35_0/libs/python/doc/index.html

В любом случае Питон в системе уже стоит. Чего страдать-то?

Оффлайн axe

  • Старожил
  • *
  • Сообщений: 1203
    • Просмотр профиля
Re: При компиляции cmake требует Boost
« Ответ #6 : 09 Февраль 2009, 03:12:10 »
Пойду в команду AlexOS64 project:D
приличный программер, там, судя по содержанию ветки, будет нелишний  ;D

Оффлайн Yurror

  • Старожил
  • *
  • Сообщений: 1966
    • Просмотр профиля
Re: При компиляции cmake требует Boost
« Ответ #7 : 09 Февраль 2009, 08:04:15 »
Python, потому что http://www.boost.org/doc/libs/1_35_0/libs/python/doc/index.html

В любом случае Питон в системе уже стоит. Чего страдать-то?
Я прочитал на кой хрен там питон появился. Это все понятно.
Питон то хрен с ним. Оно хочет вытянуть 25 метров девелоперских пакетов под этот питон. Вот от этого и страдаю.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: При компиляции cmake требует Boost
« Ответ #8 : 09 Февраль 2009, 13:23:34 »
Python, потому что http://www.boost.org/doc/libs/1_35_0/libs/python/doc/index.html

В любом случае Питон в системе уже стоит. Чего страдать-то?
Я прочитал на кой хрен там питон появился. Это все понятно.
Питон то хрен с ним. Оно хочет вытянуть 25 метров девелоперских пакетов под этот питон. Вот от этого и страдаю.
Не страдай, лучше учись готовить aptitude (apt-get, synaptic, что-то ещё...) ;)

Цитировать
$ aptitude install -s libboost-dev -R
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information     
Initializing package states... Done
The following NEW packages will be installed:
  libboost-dev libboost-serialization-dev{a} libboost-serialization1.34.1{a}
The following packages are RECOMMENDED but will NOT be installed:
  libboost-date-time-dev libboost-doc libboost-filesystem-dev libboost-graph-dev libboost-iostreams-dev libboost-program-options-dev libboost-python-dev
  libboost-regex-dev libboost-signals-dev libboost-test-dev libboost-thread-dev libboost-wave-dev
0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 2933kB of archives. After unpacking 33.8MB will be used.

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.