Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: [Wiki]Монтирование Windows-сетевых дисков (CIFS) и проблема связаная с ним  (Прочитано 135619 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн massive

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
Имеется в наличии домашний медиа-центр под управлением Windows 2003, который работает в качестве файл-сервера, медиа-центра и интернет-шлюза.
Задача: подключить сетевые диски Windows в Linux-машине.

Для того, чтобы диски автоматически подключались при запуске системы, необходимо в /etc/fstab прописать:

//[адресс сервера]/[имя ресурса]        /[куда монтируем]  cifs  credentials=/root/.smbclient,iocharset=utf8,file_mode=0666,dir_mode=0777,_netdev 0 0
А теперь разъясним что было написано выше:

credentials=/root/.smbclient - полезно, если в пароле к серверу имеются символы, типа запятой. Содержимое файла:

username=логин
password=пароль

iocharset=utf8 - кодировка файлов на сервере. Полезно указать, чтобы не было проблем отображением кириллицы в именах файлов.
file_mode=0666 - права доступа к файлам на сервере. В данном случае файлы могуть читать и изменять все пользователи системы.
dir_mode=0777 - права доступа к каталогам на сервере. В данном случае каталог может быть изменен любым пользователем.
_netdev - опция, указывающая, что данный ресурс является сетевым. Полезно, если при запуске системы будет отсутствовать сеть, тогда система не будет выдавать ошибку о невозможности примонтирования ресурсов.

А теперь о проблемы, которая присуща всем Debian дистрибутивам (Ubuntu в том числе).

Если ресурсы примонтированы вышеуказанным методом, то при перезагрузке или выключении системы, можно будет увидеть такое сообщение:

Цитировать
1.CIFS VFS: No Response for Cmd <number> mid <number>

Это связано с тем, что сначало отключаются все службы(S20sendsigs), а затем делается попытка отмонтировать сетевые ресурсы(S31umountnfs.sh). Но службы то уже отключены  :). С данной проблемой столкнулся еще с Ubuntu 8.04. В Ubuntu 9.04 она осталась.

Для ее устранения необходимо отредактировать уровни запуска, а именно rc0 и rc6. Для этого выполняем команды:

cd /etc/rc0.d
sudo mv S31umountnfs.sh S19umountnfs.sh

Те же действия необходмо проделать и в каталоге rc6.d


cd /etc/rc6.d
sudo mv S31umountnfs.sh S19umountnfs.sh

Теперь при выключении или перезагрузке системы, сначало отмонтируются сетевые ресурсы, а затем отключаются службы.

P.S. Это мой первый How-to так что прошу не сильно ругать  :). Коментарии и указания на ошибки приветствуются.

При написании темы использовалась данная статья
« Последнее редактирование: 16 Июль 2011, 18:11:05 от Дмитрий Бо »

Оффлайн yatros

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Изучил множество мануалов. Не получается прилипить при загрузке сетевые папки.
Последния версия моего /etc/fstab выглядит так: (Ну точнее последняя строка)

//servfs/обмен -t cifs '/media/obmen' -o username=admin,password=my_password,utf8 0       0
Причем все монтируется через mount в терминале отлично.  если просто зайти вручную по локалке на серв то тоже все моментально монтируется и никакого конфликта с правами и доступом нет.
В чем может быть проблема. Уже несколько дней ничего не могу предпринять. хотя все перепробовал в различных вариациях.
Машина выведена в домен по HOWTO https://forum.ubuntu.ru/index.php?topic=17941.465 может ли быть проблема из за этих настроек???
Читал маны по fstab, mount,  и еще кучу различных мануалов. Подскажите новичку. Может что то бональное делаю не так???

Оффлайн massive

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
Какая версия Убунты?
Что пишет команда mount -aТакже мысль, что сначало линукс пытается примонтировать сетевой ресурс, а уже потом войти в домен.
« Последнее редактирование: 01 Август 2009, 21:55:34 от massive »

Оффлайн yatros

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Ubuntu 9.4 Ничего не пишет, тоесть не ругается, ругается только если перед этим правлю fstab говорит что строка плохая. все равно не монтирует.

Оффлайн massive

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
У вас именно так записано в fstab?

Цитировать
//servfs/обмен -t cifs '/media/obmen' -o username=admin,password=my_password,utf8 0       0

Если да, то это не верно. Должно быть тогда так:

Цитировать
//servfs/обмен           /media/obmen          cifs            user=admin,password=my_password,iocharset=utf8      0     0
« Последнее редактирование: 02 Август 2009, 18:52:00 от massive »

Оффлайн yatros

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
не работает....
sudo mount //servfs/обмен /media/obmen -t cifs -o user=savva,password=******,iocharset=utf8Монтирует нормально без ключей -t перед cifs и -o работать не хочет. Добовляю строку в fstab, при перезагрузке ничего не происходит mount -a тоже не ругается. где у меня что криво??? Помогите пожалуйсто уже неделю с этим бюсь. Ubuntu 9,4  стоит уже на трех машинах, пробоавл прилипить монтирование на других тоже самое. не выходит.

Когда пытаюсь отсоединить папку примантированную через темринал командой mount пишет следующее [mntent]: строка 16 в /etc/fstab плохая
umount: /media/obmen не в fstab (а вы не root)
сейчас  fstab  выглядит так: # /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda1 during installation
UUID=1ef33313-4e61-4c73-88a6-fd9833349cb4 /               ext3    relatime,errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=a9571800-0bf9-4bd3-91ad-d57f67b84e14 none            swap
sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
//servfs/обмен        /media/obmen   -t cifs    -o user=savva,password=******,iocharset=utf8 0       0
« Последнее редактирование: 03 Август 2009, 11:57:27 от yatros »

Оффлайн massive

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
В файле fstab не должно быть ключей -t, -o. Они ставяться только в команде mount.
Строка должна выглядеть так:
Цитировать
//servfs/обмен        /media/obmen   cifs    user=savva,password=******,iocharset=utf8 0       0

Оффлайн yatros

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Все получилось!!!!!!  2massive  огромное спасибо))) Правельный и рабочий вариант //servfs/обмен        /media/obmen    cifs     user=savva,password=******,iocharset=utf8 0       0 В чем была проблема я так и не понял..... Единственное что уяснил что даже количество пробелов имеет значение почему то.
Осталась не решенная проблема. Есть папка на серве с названием "Документы организации" есть огромная потребность примонтировать ее. Но назавния кирилицей с пробелом fstab не воспринимает. Как можно решить это???  

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net
sudo aptitude install smbfs
sudo mkdir /mnt/local_dir
sudo mount.cifs //server/dir /mnt/local_dir -o user=USER,password=PASSWORD

Оффлайн yatros

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
sudo aptitude install smbfs
sudo mkdir /mnt/local_dir
sudo mount.cifs //server/dir /mnt/local_dir -o user=USER,password=PASSWORD

Я имел ввиду что прописать в fstab чтобы папка монтировалась при загрузке

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Попробовать «экранировать» пробел, с помощью \ или "", типа //server/Документы\ организации (обратный слэш + пробел) или "//server/Документы\ организации" но что-то гложут меня на этот счёт сомнения.

Как вариант - монтировать через fstab каталог уровнем выше, а в домашнем каталоге попробовать создать симлинк на требуемый каталог.

Оффлайн yatros

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
С вариантами "//servfs/Документы\ организации"        /media/docorg    cifs     user=savva,password=******,iocharset=utf8 0       0 и  //servfs/Документы\ организации        /media/docorg    cifs     user=savva,password=******,iocharset=utf8 0       0 не получилось. Не могу смонтировать каталог на уровень выше потому как документы организации в корне. Даже если смонтирую весь серв то не совсем понял насчет симлинка. После монтирования в папку медиа ярлыки сами появляются на рабочим столе. Тоесть с симлинком я понл, просто не хочу чтобы пользователи видели ярлык с содержимым корня серва. Переименовать папку так же проблематично.  Даже если раздам с политиками новые ярлыки это не лучший путь. Есть ли еще варианты????  

Оффлайн massive

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
Еще варианты:
Цитировать
//servfs/"Документы организации"        /media/docorg    cifs     user=savva,password=******,iocharset=utf8 0       0
Цитировать
//servfs/Документы%20организации        /media/docorg    cifs     user=savva,password=******,iocharset=utf8 0       0
Цитировать
"//servfs/Документы организации"        /media/docorg    cifs     user=savva,password=******,iocharset=utf8 0       0

Оффлайн yatros

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
вобщем тоже не помогло.. думается мне есть какой то ключик но в манах не нашел ничего (((

Оффлайн dudon

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
День добрый!

Столкнулся с выше описанной проблемой:

CIFS VFS: server no responding
CIFS VFS: no response for cmd 114 mid 11

Предложенное решение проблемы:
Цитировать
cd /etc/rc0.d
sudo mv S31umountnfs.sh S19umountnfs.sh

cd /etc/rc6.d
sudo mv S31umountnfs.sh S19umountnfs.sh

НЕ ПОМОГЛО!

Погуглил, нарыл:

cd /etc/rc6.d/
sudo mv S31umountnfs.sh S14umountnfs.sh
cd /etc/rc0.d/
sudo mv S31umountnfs.sh S14umountnfs.sh
Источник

А так же:

You can use the following work around:
cd /etc/rc6.d
ls -la

You should see :
S<nr>wpa-ifupdown the nr is probably 15
and
S<nr>umountnfs.sh that nr is probably 31

Type:
sudo mv S31umountnfs.sh S14umountnfs.sh

The point is to give the umountnfs.sh a lower as your wpa-ifupdown.sh
Источник

Как видно различия в  S19umountnfs.sh и S14umountnfs.sh.
Прокомментируйте пожалуйста.

P.S. у меня в ленни S14umountnfs.sh - вообще нет.

Пользователь решил продолжить мысль 04 Август 2009, 12:12:30:
Погуглив еще, пришел к выводу, что проблема решается у всех по разному.

Мне помогло вот это:
Цитировать
uncompress archive and set 'chmod +x' on the mountcifs file
sudo cp mountcifs /etc/init.d/

cd /etc/rc0.d
sudo ln -s /etc/init.d/mountcifs K02mountcifs

cd /etc/rc6.d
sudo ln -s /etc/init.d/mountcifs K02mountcifs

mountcifs.zip

Источник
« Последнее редактирование: 04 Август 2009, 12:12:30 от dudon »
DEBIAN Lenny  2.6.26-2-amd64

 

Страница сгенерирована за 0.06 секунд. Запросов: 24.