Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Epson Perfection V100 работает только через sudo  (Прочитано 1052 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Добрый день!

Никак не могу решить проблему со сканером Epson Perfection V100. Попробовал всё, о чём писали вот здесь:

https://forum.ubuntu.ru/index.php?topic=77721.0

https://forum.ubuntu.ru/index.php?topic=77580.0

http://help.ubuntu.ru/wiki/%D0%BF%D0%B5%D1%80%D0%B8%D1%84%D0%B5%D1%80%D0%B8%D0%B9%D0%BD%D1%8B%D0%B5_%D1%83%D1%81%D1%82%D1%80%D0%BE%D0%B9%D1%81%D1%82%D0%B2%D0%B0/%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_%D0%BC%D1%84%D1%83_epson

В итоге iscan запускается через sudo, а при запуске без sudo по-прежнему сообщает: "Could not send command to scanner. Check the scanner's status".

Исправил fstab, создал /etc/udev/rules.d/45-libsane.rules, /etc/sane.d/dll.conf тоже исправил, lsusb видит сканер, sane-find-scanner - тоже, scanimage -L - тоже никаких проблем. Что интересно, сканер определяется как устройство 004 на шине 001, но файла /dev/bus/usb/004 в системе нет, только 001, 002 и 003. Что ещё интереснее, в Kubuntu 9.04 сканер работал без проблем. Сейчас использую Kubuntu 9.10, установленную поверх 9.04. Обновление прошло со скрипом, но в данный момент система (кроме сканера) в целом работает нормально (в прошлые разы обновление до новой версии дистрибутива вообще не работало, всё ставил с нуля).

Нет ли у кого-нибудь ещё каких-нибудь идей? Похоже, моя фантазия себя уже исчерпала :-)

Спасибо

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
Re: Epson Perfection V100 работает только через sudo
« Ответ #1 : 21 Декабрь 2009, 01:31:25 »
45-libsane.rules правили? строчки со своим сканером добавляли?

з.ы подсоедините сканер в другой USB порт
« Последнее редактирование: 21 Декабрь 2009, 01:33:18 от stmc »

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Re: Epson Perfection V100 работает только через sudo
« Ответ #2 : 24 Декабрь 2009, 23:00:34 »
Файла /etc/udev/rules.d/45-libsane.rules у меня в системе не было, создал свой, он сейчас состоит из одной строчки:

SYSFS{idVendor}=="0x04b8", SYSFS{idProduct}=="0x012d", MODE="664", GROUP="saned", ENV{libsane_matched}="yes"
Пользователь включён в группу saned.

Подключение к другому порту не помогает :-(

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
Re: Epson Perfection V100 работает только через sudo
« Ответ #3 : 25 Декабрь 2009, 01:07:25 »
dll.conf правили?
должно быть так:
epkowa
#epson
#epson2
#v4l


p.s. а вообще загвоздка скорее всего в обновлении с 9.04 до 9.10
« Последнее редактирование: 25 Декабрь 2009, 01:11:03 от stmc »

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Re: Epson Perfection V100 работает только через sudo
« Ответ #4 : 16 Февраль 2010, 12:07:21 »
Добрый день ещё раз, прошу прощения за долгую паузу :-)

Цитировать
dll.conf правили?
должно быть так:
epkowa
#epson
#epson2
#v4l

Исправил dll.conf (строка v4l не была закомментирована), но и это не помогает: iscan по-прежнему запускается только через sudo.

Кстати, когда я попытался запустить XSANE через sudo (в обычном режиме она тоже не работает), она мне почему-то выдала грозное предупреждение, что запускать её с административными привилегиями опасно и делать это можно только на свой страх и риск. Не подскажет ли кто, в чём состоит опасность? Iscan таких предупреждений не выдаёт.

Цитировать
p.s. а вообще загвоздка скорее всего в обновлении с 9.04 до 9.10

А насколько велика вероятность таких сбоев при обновлении дистрибутива до новой версии? Это единичные случаи или лучше всё-таки устанавливать новую версию с нуля? :-)
« Последнее редактирование: 16 Февраль 2010, 12:12:21 от Михаил Минц »

Оффлайн dmig

  • Старожил
  • *
  • Сообщений: 1668
    • Просмотр профиля
Re: Epson Perfection V100 работает только через sudo
« Ответ #5 : 16 Февраль 2010, 13:02:33 »
Файла /etc/udev/rules.d/45-libsane.rules у меня в системе не было, создал свой, он сейчас состоит из одной строчки:

SYSFS{idVendor}=="0x04b8", SYSFS{idProduct}=="0x012d", MODE="664", GROUP="saned", ENV{libsane_matched}="yes"
Пользователь включён в группу saned.

Подключение к другому порту не помогает :-(
а какие права на устройство сканера? скорее всего это правило просто не работает.

ЗЫ кроме того, после добавления себя в группу надо перелогиниться.

Оффлайн Михаил Минц

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Re: Epson Perfection V100 работает только через sudo
« Ответ #6 : 27 Февраль 2010, 14:04:14 »
а какие права на устройство сканера? скорее всего это правило просто не работает.

ЗЫ кроме того, после добавления себя в группу надо перелогиниться.

На файл /dev/bus/usb/001/002 права 0664, как и должно быть. Так что здесь вроде бы тоже всё в порядке.

 

Страница сгенерирована за 0.057 секунд. Запросов: 24.